Data and Voice vlans not communicate to each other

Answered Question
Nov 1st, 2009
User Badges:

Dear All,


I am facing a problem that I configured the following commands on the ports of 3750 switch for Voice and data vlan


switchport mode access

switchport access vlan 5

switchport voice vlan 10



The problem is that we are using siemens IP phone for ip telephony. The phones are getting power from the switch and able to ping other phones within the same subnet but however they neither communicating with their default gateway on the switch nor the other vlans created on the switch.


However the other vlans excepts voice vlan are communicating with other.


Kindly help me in this scenario why the IP phones are not able to communicate with other vlans and their default gateway.


Regard,

Shahzad Iqbal

Correct Answer by lgijssel about 7 years 5 months ago

You are making a misstake here. The Siemens ip phone will NOT automatically join the voice vlan.

Without configuration, they will use the native vlan (5) instead.

This would explain your issue.


You can verify this by checking to which vlan the phone's mac addresses belong.

(sh mac-addr)


regards,

Leo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Muhammad Anser Khan Sun, 11/01/2009 - 03:30
User Badges:

Dear Shahzad,


I think you need to configure this port as a trunk and allowed these vlans because you are trying to connect non-cisco phone with this Cisco switch.


Following configuration may help you:


switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 5,10

switchport trunk native vlan 5


Regards,

Anser


glen.grant Sun, 11/01/2009 - 04:50
User Badges:
  • Purple, 4500 points or more

Are the phones pulling an address and appropriate default gateway ? If so then then layer 3 is working right. Make sure the default gateway assigned to the phone matches your layer 3 address for that vlan . Check dhcp scopes. Normally you should not have to trunk and the voice vlan setup you have should work ok.Do an extended ping sourcing it from the voice vlan default gateway address , if they aquired an address the phone then they should respond as it is sourced from the default gateway address. As a final consult the Siemens manual on what they normally use as a setup.

shahzad.iqbal Tue, 11/03/2009 - 01:16
User Badges:

Hi,


The siemens IP phones are not able to ping their default gateway although the ip phones and the default lies in the same subnet.


kindly help me how I can resolve this issue.



lgijssel Tue, 11/03/2009 - 01:45
User Badges:
  • Red, 2250 points or more

Please verify that the voice vlan (10) existst on all intermediate switches between the ip phone and the def-gw.

Also, all links between switches must be configured as dot1q trunks.


regards,

Leo

shahzad.iqbal Tue, 11/03/2009 - 01:58
User Badges:

These are 3750 switches and they are all connected via stack cables. Physically they are 3 switches but logically they are one due to stack feature.


lgijssel Tue, 11/03/2009 - 02:04
User Badges:
  • Red, 2250 points or more

OK, this will not be the problem then.

Re-reading your initial description, I got the impression that you may not have configured the phones to use vlan ID 10. Hence, they will use the datavlan to communicate (native, untagged) and the gw of the voice vlan will be unreachable.

You may have assigned ip adresses to the phones manually?



shahzad.iqbal Tue, 11/03/2009 - 02:12
User Badges:

I already statically assign ip address to the IP phones they are communicating to each other but not to the default gateway and other vlans. Default gateway ip address and ip phones are on the same subnet.


kindly see the configuraiton below so you will have a better idea.


interface GigabitEthernet2/0/15

switchport access vlan 5

switchport mode access

switchport voice vlan 10

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

spanning-tree portfast


interface Vlan5

ip address 172.27.121.1 255.255.255.0

ip helper-address 172.27.122.250


interface Vlan10

ip address 172.27.123.1 255.255.255.0

ip helper-address 172.27.122.250

Correct Answer
lgijssel Tue, 11/03/2009 - 02:17
User Badges:
  • Red, 2250 points or more

You are making a misstake here. The Siemens ip phone will NOT automatically join the voice vlan.

Without configuration, they will use the native vlan (5) instead.

This would explain your issue.


You can verify this by checking to which vlan the phone's mac addresses belong.

(sh mac-addr)


regards,

Leo

Actions

This Discussion