Application dial rule problem

Unanswered Question
Nov 2nd, 2009
User Badges:

I've configured the integration with Sametimes and Cucm 7. Everything works correctly, for example I can call with sametimes, but I'm not able to add/remove digit in the number to call.

I've configured the application dial rule, but it seems the call doesn't match that rule.

This is my application-dial-rule:

Number Begins With:0

Number of Digits:10

Total Digits to be Removed:0

Prefix With Pattern 0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (3 ratings)
Loading.
runmosta Mon, 11/02/2009 - 02:30
User Badges:

This is my rule for Norway


Number begins with :

Number og digist :8

Total Digist to be Removed :0

Prefix with:0


It simply add a 0 for ekst. line. We have 8 digist in Norway


Hope this helps

bagnolini Mon, 11/02/2009 - 02:35
User Badges:

Ok, but the problem is that when I make a call the system doesn't add the 0.

I tried to call a number with 10 digit that starts with 0 (for example 0123456789) but the system call 0123456789 and not 00123456789


Thanks

Lukas Auer Fri, 11/13/2009 - 06:49
User Badges:

Hi,

same problem here. I even have the exact same application dial rule. Have you found a solution to this problem yet?

lukas.

htluo Mon, 11/16/2009 - 07:47
User Badges:
  • Red, 2250 points or more

Do you have a CUPS server in the integration?


If yes, run the following command on the CUPS:


run sql select * from applicationdialrule


Copy/paste the screen output here.


Thanks!

Michael

http://htluo.blogspot.com

Lukas Auer Sun, 11/22/2009 - 07:19
User Badges:

Hi guys,


thanks a lot for your help. Sorry it took me a while to get back to you (Netpro was read-only for a couple of days and I almost didn't find my way back here with the new design ;-))


I found the solution to my problem: was a stupid mistake this time. I completely forgot the webdialer service parameter "Apply Application Dial Rules on SOAP Dial Request" is set to false by default. That's why click-to-call ignored my application dial rule. I set the parameter to true, the dial rule now gets applied to click-to-call requests as well and everything works like a charm!


Thanks again.

Lukas

Actions

This Discussion