Support for 7900-series hangup behavior in SPA9x2/SPA5xx?

Answered Question
Nov 2nd, 2009
User Badges:

Hello, we currently have a phone system with Cisco 7900 series phones.  Currently, when a speakerphone call is ended by the remote site, the 7940/7960 phone simply hangs up; no further action is required by the user.


We are preparing to transition to SPA500 series phones, and I have a SPA504G to test (as well as an older SPA942).  When the remote end hangs up, the phone sits at "Call Ended" for about 5 seconds, and then emits a fast busy until the user hangs up the speakerphone.  This is a little annoying compared to the behavior of the 7900 series phones.  Is there any way to have it automatically hang up with SPA5xx/SPA9x2?  Thanks.

Correct Answer by Steven Smith about 7 years 5 months ago

Actually, could you try changing this setting to 255.  I believe that will solve the problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
William Childs Tue, 11/03/2009 - 04:52
User Badges:
  • Bronze, 100 points or more

Ryan,


What is your call control? I assume it is a SIP pbx as you want to use the SPA9x2s. Are you using the SPA9000 or another pbx (asterisk maybe)?


Bill

Ryan Finnie Tue, 11/10/2009 - 16:38
User Badges:

Yes, SIP via an Asterisk system.  Asterisk sends a BYE to the phone when the call is completed, the phone responds to the BYE with an OK, but leaves the call open until the user hangs up.

peangvall Tue, 01/05/2010 - 12:09
User Badges:

Any update on this?  I am running 7.4.3 and I have the same issue.  On Grandstream phones, there is a setting for hangup speaker when other end disconnects and on the Cisco 79x0 it automatically disconnects, but I can't find any way to do that with these phones.

William Childs Thu, 01/21/2010 - 03:56
User Badges:
  • Bronze, 100 points or more

I have replicated the issue you are describing and I found that after 5-8 seconds it hangs up the speaker. The tone you hear is the reorder tone and that can be adjusted in the regional tab. You can set it for 2-5 seconds and still be ok.


There is currently not a way to configure how/when the speaker phone hangs up after a call disconnects.


Bill

Correct Answer
Steven Smith Tue, 01/26/2010 - 08:26
User Badges:
  • Gold, 750 points or more

Actually, could you try changing this setting to 255.  I believe that will solve the problem.

Ryan Finnie Tue, 01/26/2010 - 10:19
User Badges:

Thank you Steven!  However, I went back and double checked that field with the documentation in the SPA500 administration guide, and there appears to be an error in the documentation:


Currently it is:


Delay after far end hangs up before reorder tone is played. 0 = plays immediately, inf = never plays. Range: 0–255 seconds. Defaults to 5.


"inf" is not a valid value, nor is any number above 255; they work the same as 0.  Also, it makes it sound like using the upper range will never actually hang up the near end, just sit there.  I'm guessing "inf" was used as a placeholder when it was written before the range was defined.  It should probably read like so:


Delay after far end hangs up before reorder tone is played. 0 = plays immediately. 255 = never plays, near end hangs up immediately after far end hangs up. Range: 0–255 seconds. Defaults to 5.


Could this be noted in the errata for the next firmware release?  It is listed on both page 150 and 228.

peangvall Tue, 01/26/2010 - 08:42
User Badges:

Sweet, that fixed it.  For anybody that is curious, go to Regional and scroll down to Reorder Delay and make that 255. Don't change Reorder Tone.

Actions

This Discussion

Related Content