Device Credential report

Unanswered Question
Nov 3rd, 2009
User Badges:

Hi all,


I am running device credential reports to see if SNMPV2/V3 is ok and some devices are coming back wrong credentials/credentials not verified.


I'm looking at the date and some are from last year Dec 1 2008 and I just applied changes to some devices last night. I also verified on the device that the correct credentials are there.


Please help.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 11/03/2009 - 09:58
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Make sure that you're actually running new Device Credential Verification JOBS, and not just running the report. The report will look at old data. The job will actually refresh the data.

dionjiles Tue, 11/03/2009 - 10:10
User Badges:

That helped now I need to figure out why are the SNMP V2 parameters are showing up wrong when they are configured correctly on the device itself. Any suggestions.


Also, I'm now seeing on some devices where SNMP V3 is now configure SNMP V2 states wrong credentials.

Joe Clarke Tue, 11/03/2009 - 10:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Debugging device credentials verification is next to impossible internally. The best way to do it is with a sniffer trace. Start a trace filtering on udp/161 traffic between the server and one problematic device. Then run a new job, and check the trace to see what credentials are being used.

Martin Ermel Tue, 11/03/2009 - 10:07
User Badges:
  • Blue, 1500 points or more

Are you running this report ?

RME > Reports > Report Generator > Device Credential : Verification Report


RME Reports from the Report Generator are always based on information collected by a job and stored in the database. If this job is not configured to run periodically it is truely possible that you have outdated data in the report.

Go to RME > Devices > Device Management > Device Credential Verification Job and setup a job to check the credentials immediately, once or periodically;

At least if you let it run immediately your report should contain actual and correct data.


dionjiles Tue, 11/03/2009 - 11:50
User Badges:

I'm actually running this report Go to RME > Devices > Device Management > Device Credential Verification Job


I'm just confused as why it is stating credentials are wrong when it is the same across all the network devices.

Actions

This Discussion