reset blocker to the factory default settings

Unanswered Question
Nov 3rd, 2009
User Badges:

Hello,


I have used factory default reset button of my blocker within GUI and now my blocker is half-working. Some settings is possible to set via GUI some shows an error. I tried to reset my blocker to the factory default settings via CLI but after the suspend command an error occured, see below. Any ideas?

What is the purpose of the button which is located on the rear side of the blocker?

Thank you.


Best regards

Pavel





Welcome to the IronPort B10 Messaging Gateway(tm) Appliance

cisco.example.com> suspend

Enter the number of seconds to wait before abruptly closing connections.

[30]>

Traceback (most recent call last):

  File "pycbox_main.py", line 157, in <module>

  File "/data/lib/python2.5/imputil.py", line 103, in _import_hook

  File "/data/lib/python2.5/imputil.py", line 192, in _import_top_module

  File "/data/lib/python2.5/imputil.py", line 219, in import_top

  File "/data/lib/python2.5/imputil.py", line 274, in _import_one

  File "/data/lib/python2.5/imputil.py", line 305, in _process_result

  File "./phoebe/cli/cli.py", line 33903, in <module>

  File "./phoebe/cli/cli.py", line 25974, in main

  File "./phoebe/cli/cli.py", line 649, in command_loop

  File "./phoebe/cli/cli.py", line 32071, in do_command

  File "./phoebe/cli/cli.py", line 32322, in main_input_run

  File "./phoebe/cli/cli.py", line 32084, in run_func

  File "./phoebe/cli/cli.py", line 9421, in suspend

  File "./phoebe/cli/cli.py", line 9405, in _suspend

  File "./phoebe/cli/cli.py", line 21210, in _suspendlistener

AttributeError: 'str' object has no attribute 'keys'

AsyncOS cisco.example.com (cuad0)

login:

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bethingt Tue, 11/03/2009 - 15:08
User Badges:
  • Bronze, 100 points or more

When you did the fatory reset did were you prompt to rerun the wizard. There is no factory default button on the blocker. I would recommend reseting device and rerun the wizard.


Brian

flameflame Tue, 11/03/2009 - 22:38
User Badges:

Hi Brian,


if I try to reset my blocker via GUI, an error occures. You have to switch blocker to the offline state when you want to reset the blocker via CLI. You have to type offline or suspend command prior to the resetconfig command. When I type suspend in CLI of my blocker, a process will start which unfortunately ends by the error and login again, see above. Any ideas?


Best regards

Pavel

bethingt Wed, 11/04/2009 - 07:10
User Badges:
  • Bronze, 100 points or more

When reseting the blocker through the CLI you must place the blocker in a offline state. You can find reference to this in the Basic User Guide PDF that came with the blocker. It is located on page 460.IF that does not work I would recommend calling Cisco Small Business Support.



From the PDF


Resetting to Factory Defaults
When physically transferring the appliance, you may want to start with factory defaults. The
Reset Configuration section of the System Administration > Configuration File page, or the
resetconfig command, resets all IronPort AsyncOS configuration values to factory defaults.
This command is extremely destructive, and it should only be used when you are transferring
the unit or as a last resort to solving configuration issues. It is recommended you run the
System Setup wizard or the systemsetup command after resetting the configuration.
Note — The resetconfig command only works when the appliance is in the offline state.
When the resetconfig command completes, the appliance returns to the online state, even
before you run the systemsetup command again. If mail delivery was suspended before you
issued the resetconfig command, the mail will attempt to be delivered again when the
resetconfig command completes.
WARNING: The resetconfig command will return all network settings to factory
defaults, potentially disconnecting you from the CLI, disabling services that you used to
connect to the appliance (FTP, Telnet, SSH, HTTP, HTTPS), and even removing additional user
accounts you created with the userconfig command. Do not use this command if you are
not able to reconnect to the CLI using the Serial interface or the default settings on the
Management port through the default Admin user account.



Example of the offline cmd.


mail3.example.com> offline
Delay (seconds, minimum 30):
[30]> 45
Waiting for listeners to exit...
Receiving suspended.
Waiting for outgoing deliveries to finish...
Mail delivery suspended.
mail3.example.com> resetconfig
Are you sure you want to reset all configuration values? [N]> Y
All settings have been restored to the factory default.

Actions

This Discussion