BACD Strange Voicemail Issue "Your Message must be at least 2 seconds" when no one logged into queue

Unanswered Question
Nov 3rd, 2009

This is a very strange issue that just started monday morning (post DST change).

Here is the call flow so you can understand the problem:

PSTN --> AA 270 --> option 1 --> BACD Queue 1 EXT 790 --> if no one logged in or  no answer after 120 seconds --> BACD Queue 2 EXT 11790 (multisite extension) --> if no one logged in or no answer after 120 seconds --> BACD Queue 3 EXT 792 --> if no one logged in or no answer after 60 seconds --> AA 271 --> option 2 --> GDM 511 (for urgent support messages, also has notification to ring cell phones and send email with voicemail attached as the client has SLA of 20 minutes response time)

There are also exit parameters in all three queues for option 1 exit to GDM 510 (general non urgent voicemail) and option 2 exit to GDM 511 (urgent voicemail with notification) - these are the same options that AA271 presents.

After hours (before 7am and after 6pm Central Time) the PSTN routes to AA 270 which says we are closed option 1 GDM 510 or option 2 GDM 511.

What is happening since monday morning is that if you call during business hours and no one is logged into the queue you get sent immediately to AA 271 (as you should be) and after pressing 2 for GDM 512 you do get routed there and you hear the message and the beep but after you leave your message and hit # it says "your message must be at least 2 seconds in length, please rerecord your message and try again" you get that two times, on the third time it hangs up.  So it is not detecting your audio.

If you place the same call while an agent is logged in during normal business hours OR after hours it works 100% fine.


Business Hours agents logged in
Call 6153454702 --> routes to AA 270 --> option 1 --> users are logged in so routes to --> bacd 790 --> exit parameter 2 --> GDM 511

Does not work:

Business Hours agents not logged in
Call 6153454702 --> routes to AA 270 --> option 1 --> no users logged in so routes to --> AA271 --> option 2 --> GDM 511 – does not detect audio, gives you the message about recording a message that is at least 2 seconds in length

After hours routing
Call 6153454702 --> routes to AA271 --> option 2 --> GDM 511

New Test:
I setup a DID to go directly to AA271 (6153454712)
With agents logged in --> call 6153454714 --> AA271 --> option 2 --> GDM 511 --> works fine
With agents logged out --> call 6153454717--> AA271 --> option 2 --> GDM 511 --> works fine

also tested with DID going directly to GDM 511, works with or without users logged into BACD queues

So the problem is not in the AA or the GDM, it has something to do with BACD

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
johnconrick Tue, 11/03/2009 - 14:36

attached is

debug voip rtp err

Placed the call with users logged in and this command:

sh voip rtp connections

Did same thing when everyone is logged out.

Also grabbed 'sh call hist voice last 2' after each call.

johnconrick Tue, 11/03/2009 - 14:29

here is the capture i did of the message I left and the voicemail system then prompting me on the 2 seconds (it did not recognize audio being captured).

EDIT: This capture shows that the audio is silent going to the CUE card.

Message was edited by: johnconrick

johnconrick Wed, 11/04/2009 - 14:54

This appears to be a bug with CIPCs that were configured with a button to monitor a DN that was assigned to the GDM.  None of them were active at the time of the problem, but after removing their ephone from the config - the problem appears to be resolved.  These ephones had been dormant on the system for at least a month with no changes, so this is a new problem that just started occuring on Monday November 2nd.


This Discussion