SPA941 Deployment and Provisioning

Unanswered Question
Nov 4th, 2009

I have a 50+ phone system using SPA941 phones. I have manually configured each phone and we are getting ready to launch more. I have successfully created an auto-provision master cfg file (spa941.cfg) and a phone specific cfg file (spa000e08d2ca16.cfg) - which in a test environment, utilizing TFTP downloaded and installed the provision settings correctly. I also indicated that the firware autoupdates from version 4.x (Sipura) to Cisco spa941-5-1-8.bin. I have also caught the DHCP OFFER packet in which I am using dhcp-option:66,"ip-address" - which is coming correctly thru (ironically on the bootp "server name" param). After updating the firmware - the phone has stopped auto-provissioning and will not retrieve the ftp server name (Profile Rule). I have done factory resets, hard boots, soft boots - you name it. I may have answered my own question, but has anyone ever encountered this? I may rollback to the original firmware...

Help!

UPDATE:

I have reverted back to the sipura spa941-4-1-15.bin image with no luck.  I seems that the Profile Rule (for the ftp server address) is not pulling down correctly.  Now - I am using a Linksys WRT54GL router flashed with Tomato (stripped down OpenWRT) that has dhcp-option 66 configured as an additional param in the dnsmasq service.  Using wireshark I inspected again and observed that the phone will not pick up the server name.

THE ONLY THING is that I don't see and explicit OPTION=66 in the DHCP Offer packet - is this correct?  The ftp server is in the  bootp "server name" param - and that worked the original time I took the phone out of the box.

Capture1.jpg

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ChrisCogdon Fri, 11/27/2009 - 22:40

This might be really silly, or the solution... i didn't think the phones could do FTP. Your choices were TFTP or HTTP. If that was a mistake, then you need to change the server name to "tftp://example.com" rather than "ftp://example.com"

shawnbure Tue, 02/23/2010 - 13:33

For anyone that wants to know - both posts helped.  The last post was correct - the Linksys SPA941 does not do ftp even though it says it does - only tftp and http!

shawnbure Sun, 07/18/2010 - 13:23

For tomato users - the option dhcp-options-force=66,192.168.x.x will make the DHCP Option 66 come through the actual DHCP options.  If you use dhcp-options=66,192.168.x.x it will only come through the bootp otions.

Patrick Born Tue, 11/10/2009 - 17:09

Hi shawnbure,

I have also caught the DHCP OFFER packet in which I am using dhcp-option:66,"ip-address" - which is coming correctly thru (ironically on the bootp "server name" param).

This is correct, bootp is the ancestor of DHCP this is why you filter with bootp in WireShark when filtering for DHCP. :-)

I'm guessing that the DHCP server is not appropriately configured to supply the TFTP server's IP address. No two DHCP servers are the same. Here's what my /etc/dhcp/dhcpd.conf looks like:

subnet 192.168.2.0 netmask 255.255.255.0 {
authoritative;
interface eth0;
range 192.168.2.155 192.168.2.180;
default-lease-time 1800;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.2.255;
option routers 192.168.2.254;
option domain-name-servers 24.93.41.125, 24.93.41.126;
option tftp-server-name "192.168.2.245";
option ntp-servers pool.ntp.org;
}

This is what you should see [Click image to view bigger]:

Take a look at this document that shows the entire trace of the boot sequence in the back-matter: https://supportforums.cisco.com/docs/DOC-9954

Regards,

Patrick

-----------

Actions

This Discussion