GRE Tunnel recursive routing

Unanswered Question
Nov 6th, 2009

Hi Experts,

I am simulating a tunnel recursive routing problem using 3 routers. I am using OSPF

(area 0)--R0--(area 1)--R1--(area 1)--R2--(area 2)

R0 Loopback: 1.1.1.1 /32 (advertised in Area 0)

R2 Loopback: 3.3.3.3 /32 (advertised in Area 1)

When GRE tunnel is created using Tunnel source as corresponding Loopback IP address, Tunnel recursive route error start prompting & Tunnel goes down / flapping. I know this is a usual behaviour.

So, I have 3 method to handle this

1. Using static route for Loopback with gateway of serial interface

2. Increase the admin distance to 130 (just an example) for Loopback prefix alone in OSPF process

3. Distribution-list using prefix-list in R0 & R1

I chosed and trying 3rd method (Distribution-list). But it is not working. My example is below

R0:

ip prefix-list LB-3 deny 3.3.3.3/32

ip prefix-list LB-3 permit 0.0.0.0/0 le 32

distribution-list perfix-list LB-3 in tunnel 1


interface tunnel 1

ip add 10.10.10.1 255.255.255.0

tunn source 1.1.1.1

tunn destination 3.3.3.3

R2:

ip prefix-list LB-1 deny 1.1.1.1/32

ip prefix-list LB-1 permit 0.0.0.0/0 le 32

distribution-list perfix-list LB-1 in tunnel 1

interface tunnel 1

ip add 10.10.10.2 255.255.255.0

tunn source 3.3.3.3

tunn destination 1.1.1.1

I thought that in R2 prefix 1.1.1.1 will not be installed thru Tunnel interface. But it is not working.

Please help me to finding out what mistake I am doing. I have tried various option. No clues.


sairam

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
simontibbitts Fri, 11/06/2009 - 01:53

Hi Sairam


Have you tried a 'clear ip ospf process' after doing your config change?


('clear ip ospf redis' might work too)


I have found that sometimes OSPF distribute-list does not work until you do a clear.


Cheers

Simon

snarayanaraju Fri, 11/06/2009 - 03:03

Hi simon,


Now i tried clear ip ospf process in all the routers.


But this issue still exist


sairam

snarayanaraju Fri, 11/06/2009 - 20:37

Hi Friends,


Any clues. I am eagerly waiting for your response.


The same scenario, I am able to achieve using EIGRP / RIP using Distribution-list "OUT" keyword. But whereas in OSPF i have only the option of using Distribution-list "IN" as no use of "OUT" keyword in OSPF.


Please help me where is the mistake


regards and thanks in advance


sairam

snarayanaraju Mon, 11/09/2009 - 00:10

Hi friends,


Again I starting the thread. Excuse please.


But if you have solution please share with me. It is eating my heads even though the issue is not as important


sairam

Actions

This Discussion