SPA525G Stuck in reboot loop

Answered Question
Nov 6th, 2009

I was trying to change the wallpaper on my SPA525G and I entered a URL but forgot to include the "http://" in front of it.

After saving the settings, the phone rebooted and is now stuck in a reboot loop. Each time it gets to the picture of the phone with an arrow pointing to a cloud and then restarts again.

I can't get into the web interface.

Is there a way for me to clear the settings to either fail-safe or factory defaults so I can recover my phone?

Cheers

Paul

Correct Answer by Patrick Born about 7 years 3 months ago

Hi Paul,

The phone can usually display the setup menu from pretty early in the boot cycle. Try press the menu button even though it look like it may not be available, perhaps the menu will be available.

The menu feature is usually available before the phone starts looking for network information.

Regards,

Patrick

-----------

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
hotstartsw Fri, 11/06/2009 - 18:03

Thanks for the suggestion but unfortunately even without the Ethernet cable in, it still wont boot as far as the menu.

Correct Answer
Patrick Born Mon, 11/09/2009 - 07:44

Hi Paul,

The phone can usually display the setup menu from pretty early in the boot cycle. Try press the menu button even though it look like it may not be available, perhaps the menu will be available.

The menu feature is usually available before the phone starts looking for network information.

Regards,

Patrick

-----------

hotstartsw Mon, 11/09/2009 - 17:52

Trying to bring up the menu before it was ready worked. Thanks for the suggestion.

It was a little trickier in that I still couldn't do a factory reset (gave an error saying it can't be reset whilst in the call) but it did delay the reboot long enough so that I could get into the web interface and remove the offending setting and regain control of the phone and then do a factory reset.


Thanks for your help.

Paul

Patrick Born Tue, 11/10/2009 - 17:34

Paul,

That's great news! I'm pleased that you've been saved the bother of RMA'ing the SPA525G. Thanks for your patience and also for letting me know.

I changed my phone's config to match yours but could not get it to boot-loop.

If you're feeling brave and have some time, it'd be great if you could update your phone's firmware and test again.
https://www.myciscocommunity.com/docs/DOC-11915

If you're able to replicate the issue, I'll open a CDETS against this to save others from the misery you experienced.

Regards,

Patrick

-----------

hotstartsw Sun, 11/08/2009 - 18:46

Just for everyone else's benefit. After spending about an hour on the phone to Cisco, they issued a RMA# so I am seeking a replacement with the supplier.

I've got to say I'm a little disappointed there is no factory reset button on the back of the phone or a key combination at bootup that can restore the phone to a failsafe configuration.

Patrick Born Mon, 11/09/2009 - 07:06

Hi Paul,

Can you help me replicate what you did please? I've tried my lab but cannot get my SPA525G to boot-loop.

Here's what I changed:

cap_vl-0018.jpg

Do you recall what version of firmware the phone is running?

Regards,

Patrick

----------

hotstartsw Mon, 11/09/2009 - 17:56

Here's the information so you can see if you can replicate the problem.


I'm on firmware 7.1.7.

I set the picture to www.hotstartsoftware.com/hs525g.bmp (without entering "http://")

I'm also fairly sure I didn't change the "Background Picture Type" like you did.

Hope that helps.

Paul

rseals Thu, 12/10/2009 - 14:21

I have managed to do the same thing with one of my SPA525G phones running 7-3-5 firmware.  Ironically it was messing with the background wall papers that did it.  I cannot get the menu to come up.  I setup a laptop with a DHCP and TFTP server and long with wireshark.  The Phone boots and gets a DHCP address and then just sits there.

Here is the configuration file that has it screwed up:



http://stlmosipsvcs01.magellanhealth.com/spa525g-7-3-5.bin
XXXXXX
3600
10.200.2.250



2
3600
14400

GMT-06:00
YES

MHS St. Louis
MHS St. Louis
MHS St. Louis
Text Logo
98765
stlmosipsvcs01.magellanhealth.com
http://stlmosipsvcs01/images/christmas02.bmp
Download BMP Picture

77589
77589
7758901

hotstartsw Thu, 12/10/2009 - 19:08

Hi rseals

Did you manage to get out of the reboot loop with your phone?

I found that if I repeatedly pressed the menu button when it was rebooting, I could gain enough control to get back into the web interface and remove the erroneous settings and then do a factory reset.

Paul

rseals Fri, 12/11/2009 - 04:52

No, I have tried many, many times booting the phone and pressing the menu button with various frequency (i.e. once every second during the boot, every 2 or 3 seconds).  Did you notice while you are pressing the boot approximately when did it give you the menu, what was the screen showing, and did it give you the normal menu?  By normal menu I mean, did it clear off the screen and give you the standard gui menu.

hotstartsw Fri, 12/11/2009 - 06:06

Its a little while ago now but from memory, it was quite late in the boot process (well after the Cisco logo). I seem to recall it was on the screen with the phone and cloud. I was pushing the button about once every 1 to 2 seconds.

Yes, it cleared the screen and displayed the usual menu. At that screen, I couldn't do a factory reset  (told me I was in a call) but I seem to have been able to stall the boot/reboot process long enough to get into the web interface and remove the background image settings. It took me a few times to get it right.

Once I did that the phone booted normally for long enough to do a full factory reset (seemed unstable otherwise) and since that its been great.

Hope that helps. Good luck.

Paul

mjendrian Fri, 12/11/2009 - 07:48

Hello,

I found myself with two phones in this reboot-loop. After reading this thread I tried to mash the menu button as often as possible to get into the settings screen. I never had any success with this.

However I had entered a valid address into the "" field. The phones just did not like my BMP picture. So I did copy the contents of a JPG image into the BMP file, which the phone tried to download from our web-servers. (keeping the BMP-extension). The phones did download and show the JPG file correctly and worked normally after that.

Another aproach could be, to use a dhcp server with tftp-config option set to get other parameters from a tftp server. I would have tried this next.

I wish yo good luck with your problem.

Kind regards,

Martin Jendrian

LinkSIP

rseals Fri, 12/11/2009 - 11:40

It has replaced the Cisco Logo with the wallpaper that I put on that subseqently put me into the problem.  No amount of hitting the menu key at any point during the boot process will break it out of the cycle.

The strange thing is it never tries to pull the config again from the server.  I have run tcpdump off the server where it pulls the image and the config.  It will get an IP address from a DHCP server sit there and reboot.

I'm really at a loss here.

icastrov Mon, 12/14/2009 - 00:25

Dear Sir,

this is an open issue that has been filed as a BUG into CDETS, the case number is CSCtd63373 in the case you want to track it.

Thanks!

-nacho

Alberto Montilla Mon, 12/14/2009 - 07:20

Dear Sirs;

Please try pressing the speaker button several times after the Cisco Logo appears (it is not the menu but the Speaker button). This should bring you to the emergency menu.

Regards
Alberto

rseals Mon, 12/14/2009 - 08:14

Speaker button worked!!!!

I performed a recovery reset.  Not sure what that does, but I can now access everything and loop has been broken!!!!

Thanks SO much.

nomadoVoIP Thu, 12/02/2010 - 14:13

Hi Guys,

Just have a 525G today with FW 7.4.5

Working perfectly with nomado VoiP

Everything ok BUT.... when I put a image url on the "BMP Picture Download URL" and of course : "Background Picture Type: " Download BMP Picture

Whatever format I put .gif .jpg .bmp it freezes 15 sec and then reboot and even stuck in reboot in loop

Thanks to the speaker button, I can stop the loop..

But it seems that putting a nice logo image is not possible .. too bad

The stange thing is that it was working one hour ago, and with finetuning the size of the image (not written anywhere the exact size) it satrted to crash in loop..

Maybe I should download the new firmware? Can I do it easily with a Mac?

Thanks so much

Olivier

Patrick Born Thu, 12/02/2010 - 14:57

Hi Olivier,

It could be that there are issues with the images that you're attempting to use. To eliminate this possibility, please try some known-good images.

There are sample images attached to the following link that you can use to verify and perform a sanity check: https://supportforums.cisco.com/docs/DOC-9940

If the phone continues to misbehave then load 7.4.6 on your SPA525G. It and release notes are available from Cisco.com

There are links in the reference document, listed below, that point to locating firmware if you need help.

You should have no problem upgrading the SPA525G. Direct your browser to /admin/advanced">http:///admin/advanced

Top-right of the page, click on Firmware Upgrade, locate the firmware on your computer, and upgrade.

Regards,

Patrick

----------

You only need one reference document for all SPA phone firmware, information, and utilities.

nomadoVoIP Thu, 12/02/2010 - 15:40

Thanks Patrick

It did'nt helped to upgrade the FW to 7.4.6

Still the same issue and i tried different public image URL.. same prob, it reboots in loop.

It is late now in Europe so I'll try tomorrow to choose different format, just have used jpg on the 7.4.6

Thanks again

Olivier

Patrick Born Mon, 11/09/2009 - 07:38

Hi Paul,

You asked, "Is there a way for me to clear the settings to either fail-safe or factory defaults so I can recover my phone?"

Yes, when a phone boots, it looks for a configuration server. If you make a configuration server available, you can have the phone overwrite any configuration that needs changing, provided the phone has not been locked by a service provider, of course.

Scan through this zero-touch configuration document: https://supportforums.cisco.com/docs/DOC-9954

Starting on page 6 is a diagram and description of the phone's boot process.

Page 14 shows traces from when the phone issues a DHCP DISCOVER to the network, the document describes the phone's boot process.

Starting on page 9, I show how to build a configuration file for the phone.

You could do the following to recover your phone:

1. Build a file with the following content to clear out any wallpaper related configuration and then reboot the phone:


Yes
10

Default

Default



2. Save the file as spa525G.cfg [case is sensitive, note upper case G, everything else is lowercase]

3. Configure a TFTP server

4. Configure your DHCP server to offer option 66, the IP address of the TFTP server from step 3

5. Reboot the phone

6. The phone will reboot and load the new config file

Regards,

Patrick

---------