SDM Launcher fails: "You have an active popup blocker. Please disable it."

Unanswered Question
Nov 6th, 2009

XP sp 3

SDM (Security Device Manager) (tried 2 latest version with identical outcome).

I launch SDM and it complains: "You have an active popup blocker. Please disable it for SDM to function.

But I have on IE the popup blocking turned off (Tools -> Popup Blocker).

I posted here since I could not find an SDM specific forum. And I am trying to get CCNA.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jbrenesj Fri, 11/06/2009 - 15:14

I fixed it once with the procedure below:

Open the explorer and go under tools and Internet Options, click on

Advanced and scroll down until finding Security. Check: "Allow active

content to run in files on My Computer" and after this clear the cache and close all explorer windows.

johnlloyd_13 Sun, 11/08/2009 - 16:55

try other web browser, uninstall and re-install ie or do an exception:

Tools > Internet Options > Privacy > Settings > Allow the IP address you use for your SDM

jeremakela Sun, 11/08/2009 - 23:19

I already updated IE to the latest version with no effect. I don't know how to run SDM with another browser.

And I tried Tools -> Internet Options -> Privace -> Settings and allowed with not effect.

I have also Vista machine with SDM installed. It also gives an error message, but different (I use

"Unable to launch SDM due to one or more of the following reasons:

(1) The IP address or hostname you provided is not a valid router address or is not reachable

(2) HTTP/HTTPS is disabled on the router. SDM requires HTTP or HTTPS to be enabled on the router. If you are running HTTP or HTTPS on a custom port, specify the port number along with the device IP address or hostname (e.g.

After you have fixed these problems, try again.

So yadda yadda in here too.

jeremakela Mon, 11/09/2009 - 03:31

SDM failure on XP solved out.

It was Google that blocked popups, not IE.


This Discussion