Nortel - Cisco integration

Unanswered Question
Nov 6th, 2009

Hello All,

I have an issue with a Nortel to Cisco integration - we have a Nortel option 61 and we are trying to move voicemail over to a 3rd Party voicemail box (Interactive Intelligence) that sits on the Cisco side of the house. Call flow is as follows:

call comes into a Cisco VG2851 using MGCP.

VG sends call across network from MGCP GW to an H323 GW that has a PRI trunk using DMS100 signaling into Option 61. DMS100 is the only way we can get redirect info which I believe is what we need to see.

If Nortel handset rings out cfna sends call back to Cisco side with the called party number being the voicemail pilot. The issue is that when the calls gets sent back to the H323 GW with a redirect number of the handset it does not route back to the Cisco side but unfortunately just redials the Nortel handset over and over. If we configure the Cisco to Nortel trunk as NI or QSIG we do not get redirect info but the call does route to the voicemail server but does not ring into the handset voicemail box as it sees the call coming from the original calling party number. If anybody has any experience integrating this as such any information or advice would be appreciated. The proper dial peer info is in place because it does get routed properly using NI or QSIG.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
iptuser55 Mon, 11/09/2009 - 02:47

Under Service Parms>Call Manger>Forward, there are a couple of settings Include Qsig Directing VM, Copy QSIG DirectingNR, Copy QSIG Diversion etc try these out particularly Include Voice Mail

pcaltagirone22 Mon, 11/09/2009 - 08:06

Thanks for the reply! - The only way we are seeing redirect in the Q931 debug is through the DMS100 to SL100 tie trunk on the H323 gateway to Nortel link. Is there any way to make changes to that trunk setting on the CM side? After further debugs it appears that the calls do get forwarded back to Call Manager through the H323 GW, but it is redialing the original called number as if it is using the called number field to route call as opposed to using the redirect field.

Thanks again!

iptuser55 Mon, 11/09/2009 - 09:31

We had this issue at CUCM 3.X and was part of a beta prgram and so hence the parms were added. I think you need play with the settings I mentioned I think it is the "copy" ones you need to tick - select them one at a time and then retest


This Discussion