Rate limit 2960 Port to 1 MB

Unanswered Question
Nov 6th, 2009

Please let me know how to rate limit the 2960 switch port to 1 MB.

I have made the specified chnages , how ever still it is reaching more tha 1 MB

Hard coded the bandwidth of port to 10 MB and have applied the specified command

srr-queue bandwidth limit 10

Still the computer on that port is reaching more than 1 MB

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
sridsdale Fri, 11/06/2009 - 13:35

In which direction does the traffic surpass 1Mb/s?

The srr queue commands are for egress only. If you want to limit ingress as well then you need to add a service policy to the interface that polices traffic to the required rate.

Also the srr-queue bandwidth limit command is not exact so you may see traffic egress the port above the set rate.

jbrenesj Fri, 11/06/2009 - 15:06

1) Enabled QoS globally...

2960(config)#mls qos

2) Configure an ACL to define the matched traffic...

2960(config)#access-list 111 permit ip any any

3) Configure a class map for the matched traffic...

2960(config)#class-map traffic

2960(config-cmap)#match access 111

4) Configure a policy-map to define action...

2960(config)#policy-map Control

2960(config-pmap)#class traffic

2960(config-pmap-c)#police 10000000 8000 exceed-action drop

5) Attached the policy-map to the interface.

a) Example

-In this case, I'll attach the policy map to port_1....

2960(config)#int fa0/1

2960(config-if)#service-policy input Control

>>>>>> This will rate-limit traffic coming from the PC

frank_iosoft Wed, 09/26/2012 - 06:22

Tried this solution on my WS-C2960-8TC-S V.12.2 but class-map and policy-map command does not seem to work.

Is there any solution for that?

singhaam007 Wed, 09/26/2012 - 20:26

Hi Frank,

try to upgrade ios and then try or you already on latest one ??

here is the example from my 2960 (55)

mls qos

ip access-list extended ACL_SLAP
permit ip any any

class-map match-all CLASS_SLAP
  match access-group name ACL_SLAP

policy-map POLICY_SLAP
  class CLASS_SLAP
    police 1000000  exceed-action drop

interface GigabitEthernet0/2
service-policy input POLICY_SLAP


naitikchaitanya Thu, 07/03/2014 - 05:20

Hello Singhamm,

We have the following commands which you gave on our cisco 2960 switch but its just limiting my upload traffic (Egress) we can not limit our download speed(ingress),

We have checked the speed for the following on that ports via speedtest.in but still we are getting the maximum for the download. i am attaching the configuration please help me with this and do reply on [email protected]

I will be grateful if i receive help from any one.





This Discussion