Giuseppe Larosa Sun, 11/08/2009 - 04:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mohamed,

on routers I've used CLNS in a GRE tunnel.


so that CLNS pdus are placed inside a GRE packet.


you may need to tune clns mtu to be able to run ISIS for CLNS over the GRE tunnel.


check what options you have under a tunnel interface


interface tunnel x

clns router isis

clns mtu 1460

tunnel source ip1

tunnel destination ip2

tunnel mode gre


Hope to help

Giuseppe


mohamedmk75 Sun, 11/08/2009 - 05:01
User Badges:

Hi

Thanks for your reply,

please i need to know how to force the OSI traffic to goes through the tunnel based on the attached topology



Giuseppe Larosa Sun, 11/08/2009 - 05:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mohamed,

it is enough to configure both C7609 with a tunnel GRE (if supported)


clns isis -> routing CLNS packets over the tunnel


you shouldn't need anything else.


I used this system to carry CLNS traffic inside an MPLS VPN.


the real problem is that I'm afraid C7609 don't support CLNS routing.


if so you can use an EoMPLS tunnel to carry CLNS traffic over the IPv4 cloud (it requires MPLS enabled in the cloud)


or EoMPLS over a GRE tunnel.



Edit:


I see clns supported in a C7609 in my network


clns ?

cache-invalidate-delay Delay CLNS route cache invalidation

configuration-time Define the rate at which ESH and ISH packets are sent

filter-expr Define CLNS filter expression

filter-set Define CLNS filter set

holding-time Holdtime advertised in ESH/ISH PDUs

host Define a name mapping for an NSAP address

net Define a Network Entity Title (NET)

packet-lifetime Define initial lifetime for locally generated packets

route Define a CLNS static route

>>> routing Enable clns routing

security pass-through Do not reject packet with security options set

template-alias Define CLNS template alias

want-erpdu Request error PDUs on packets sourced by router


this device is using

sh ver | inc image

System image file is "bootdisk:c7600rsp72043-advipservicesk9-mz.122-33.SRC.bin"


So I think the CLNS over GRE approach can be used.


the device will route CLNS packets and IPv4 packets




Hope to help

Giuseppe


mohamedmk75 Mon, 11/09/2009 - 03:01
User Badges:

i tried this config based on attaeched topology, its not working, i want to exchange isis routing updates between the two sites and also the traffic between two sites


config


=====================================================

en

conf t

hos R1

int fast 0/0

clns mtu 1460

clns router isis

no shut

exit

router isis

net 49.0001.0000.0000.0001.00

interface fast 0/0

clns router isis


--------------------------------------------------

en

conf t

hos R2

int fast 0/0

no shut

clns mtu 1460

clns router isis

exit

int ser 1/0

no shut

ip add 10.1.1.1 255.255.255.0

exit

interface Tunnel 0

ip address 17.1.1.2 255.255.255.252

clns mtu 1460

clns router isis

tunnel source fast 1/0

tunnel destination 10.1.2.1

tunnel mode gre ip

exit


router isis

net 49.0001.0000.0000.0002.00

interface fast 0/0

clns router isis

--------------------------------------------------

--------------------------------------------------

en

conf t

hos R7


int se 1/0

no shut

ip add 14.1.1.2 255.255.255.0

exit


int fast 0/0

no shut

clns mtu 1460

clns router isis

exit


interface Tunnel0

ip address 17.1.1.1 255.255.255.252

clns mtu 1460

clns router isis

tunnel source fast 1/0

tunnel destination 10.1.1.1

tunnel mode eon

exit

router isis

net 49.0002.0000.0000.0007.00

interface fast 0/0

clns router isis


--------------------------------------------------

en

conf t

hos R8

int fast 0/0

clns mtu 1460

clns router isis

no shut

exit

=====================================================





Giuseppe Larosa Mon, 11/09/2009 - 03:22
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mohamed,

in global config


clns routing


is needed


Hope to help

Giuseppe


Actions

This Discussion