CUCM 4.1.3: makeCallSoap: error "service "WebDialerSoap' unknown

Unanswered Question
Nov 9th, 2009

I posted my issue on developer community ( but did not receive an answer yet (last 14 days) so I post it here again:

Hi all,

I am developing a little Webinterface for a Click-to-dial application using the SOAP-Interface for Webdialer because we do not want to use the JavaScript/Cookie-Interface any longer.

I have been already successful with CUCM 6.1 but I am running into trouble with CUCM 4.1.

Following the "Cisco WebDialer API Reference Guide Version 4.1" page 9 ff. my request looks like this (Private parts are *** out):

POST /wdsoap/servlet/rpcrouter HTTP/1.0

Host: ********

User-Agent: NuSOAP/0.7.3 (1.114)

Content-Type: text/xml; charset=ISO-8859-1

SOAPAction: ""

Authorization: Basic Y2NtYWRtaW5pc3RyYXRvcjpjYWxsNHU=

Content-Length: 631

<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="" xmlns:SOAP-ENV="" xmlns:xsd="" xmlns:xsi="" xmlns:SOAP-ENC=""><SOAP-ENV:Body><ns4311:makeCallSoap xmlns:ns4311="WebdialerSoap"><Credential><userID>******</userID><password>******</password></Credential><dest>12345</dest><UserProfile><user>*****</user><deviceName /><lineNumber /><supportEM>true</supportEM></UserProfile></ns4311:makeCallSoap></SOAP-ENV:Body></SOAP-ENV:Envelope>

Response is this:

HTTP/1.1 500 Internal Server Error

Server: Microsoft-IIS/5.0

Date: Tue, 27 Oct 2009 07:53:53 GMT

Content-Type: text/xml; charset=utf-8

Content-Length: 477

Set-Cookie: JSESSIONID=57C0871B97F59B1E56F375127F672636;Path=/wdsoap

<?xml version='1.0' encoding='UTF-8'?>

<SOAP-ENV:Envelope xmlns:SOAP-ENV="" xmlns:xsi="" xmlns:xsd="">




<faultstring>service 'WebdialerSoap' unknown</faultstring>





Same Request with other URL and ServiceName works fine with CUCM 6.1.

Any idea?

Thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)


This Discussion