CCX Prem 7 script help- Send out Email after waiting in queue 1 minute

Unanswered Question
Nov 9th, 2009

Does anyone have created any scripts to send out an email?

For example, how to create the script for the following scenario: when caller is in the queue for 60 sec, the script sends out an email to notify supervisor with caller tel nr included in the emailbody.

I tried to use Creat eEmail Step, Attach eMail Step, SEnd eMail Step but run into errors. How to get caller tel nr (ANI)and paste it into email? Thank you in advance,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
simonandorfi Mon, 11/09/2009 - 11:31

This should be easy to do in CRS Scripting. The steps that you've descibed should do exactly what you want.

What erros have you seen`?

To get the ANI in the email, just use Variables in the emailbody configuration. I can send you an example script if this helps.

HowYee Wed, 07/27/2011 - 22:06

Hi Gundars,

Did you successfully sending out email? I'm having the same problem.

how Yee

HowYee Thu, 07/28/2011 - 00:08

Hi Gabriel,

I plan to attach the voice recording in the email. Somehow I can't send out the email. It goes to the unsuccessful branch. I'm using thunderbird 3.1.11, hMailServer 5.3.3 and a domain name -> You can view more details from the attchment.

Any ideas?


How Yee

Gabriel Saavedra Thu, 07/28/2011 - 07:15

Can you ping from your UCCX server?...what about using the IP address of your smtp relay.


HowYee Thu, 07/28/2011 - 23:24

Hi Gabriel,

I can ping successfully. Is the attachment as what you mean for smtp relay?


How Yee

Aaron Harrison Thu, 07/28/2011 - 10:25


Try removing the 'attachment' steps, and see if a plain text email goes through OK. I had the same problem the other day, but put it down to a problem with the customers mail server that he believed was being decomissioned. No attachments, all was well.

It may well be a bug with UCCX7 on the particular SR they run (previously it worked fine).


HowYee Thu, 07/28/2011 - 23:11

Hi Aaron,

Still the same problem even I remove the attachment.


How Yee

HowYee Wed, 08/03/2011 - 20:56

Hi guys,

I solved my problem at last, it is the authentication that makes me crazy...

Thanks for your response.


How Yee


This Discussion