No VOIP phones in UT

Unanswered Question
Nov 9th, 2009

Background:LMS 3.1:Campus 5.1.3;CS 3.2; Portal 1.1.0;RME 4.2

------------------------

I can see the call managers with their associated icons in the topology maps and have verified snmp access via SNMP walk. I ran data collection and acquisition to no avail.

I noticed that the call managers (7845H MCS) are unable to have their inventory collected due to "RICS0001:Internal Error,unable to process the collected data from the device." I wanted to know if inventory collection of the Call manager is a requirement to get the phone info in UT. If so I checked the ICserver.log and found the following errors:

( Inventory: CISCO-ENTITY-ASSET-MIB attributes not supported by the device) &

(SQL Anywhere Error -193 primary key for table "software Element" is not unique)

I appologize for not attaching logs as I am prohibited. So I completely understand if I am unable to continue this post. I was hoping that I am just missing something simple or that you could point me in a direction

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 11/09/2009 - 12:21

Inventory Collection is not required to find phones in UT. What is required is that the CCMs support the ccmPhoneTable and the CISCO-CCM-MIB. The phones should also show up as end hosts in UT, so the switches to which they connect must also be managed by Campus Manager.

john.caterino Tue, 11/10/2009 - 04:29

I will verify the version of call manager, but is there a standard MAC address or something to query in UT to verify that phones are there as end hosts?

Joe Clarke Tue, 11/10/2009 - 08:48

No, you need to search the UT end host table for the MAC of a known phone.

john.caterino Thu, 11/12/2009 - 05:15

Well, I found a group of phones that show up as end hosts but not as phones.

The switch they are on is managed and visible in Topology services with the CCMs, which I am told are CUCM version 6.1.2 I did notice that the "acquisition Information" page shows only 1 in the "Number of CCM Hosts" when there are 3 in Topo maps. I added the check under UT Admin...to "Enable end hosts discovery on all trunks" I did pick about 60 phones but not the ones I was looking for and still several hundred short of the total. i was also wondering if I need HTTP credentials in the DCR for the Call Managers?

Joe Clarke Thu, 11/12/2009 - 09:30

No, SNMP only is required for CCMs. You say you are on CM 5.1.3, but it sounds like you're actually running an older version. CCM 5.x+ support wasn't added until 5.1.3, so Campus may only be recognizing older CCMs as actual Call Managers. Post a screenshot of the topology map showing the CCM to which the missing phones are registered.

john.caterino Thu, 11/12/2009 - 09:57

I have attached a file with the version info (i just copied from screen) in the hopes that you recognize that maybe I am missing an incremental update or something.. Unfortunately I can not get a screen shot of the topology map icon from that network. It is a green server with an open box in the front left corner that is white with a green stripe.. again I appologize for not being able to provide the files you requested.

Joe Clarke Thu, 11/12/2009 - 10:00

Nothing is attached. However, it doesn't sound like I'm going to be able to offer any more help without seeing more details. I recommend you open a TAC Service request so debug logs, configs, and screenshots can be provided.

john.caterino Thu, 11/12/2009 - 10:08

Sorry about that...I have attached it this time just incase you catch anything with a quick look, otherwise I will end this thread. Thanks for the help!!! I held off on the TAC case up til this point because I can not give them the files or screen shots either.

Joe Clarke Thu, 11/12/2009 - 10:11

It's going to be very hard to troubleshoot your issue, then. This version of Campus does support your CCM software version, and it sounds like the CCM is being properly managed as an application server. Try walking its ccmPhoneTable using the SNMP Walk tool in Device Center. Make sure this is returning valid data.

john.caterino Thu, 11/12/2009 - 10:59

Was able to snmpwalk the device and searched the output for "ccmPhoneTable" and "phone" with no results, although I see plenty of references to phone IP addresses. I did notice the first line

lists the software as

"Softwrae:UCOS 3.0.0.0-60" could this be the actual ccm version which might require addition configuration of the 7845H2? Also there was no reference to the CISCO-CCM-MIB...

Joe Clarke Thu, 11/12/2009 - 11:02

No, this is the OS version, not the CUCM software version. You need to perform an SNMP Walk with the starting OID of ccmPhoneTable, and make sure you get results. If not, your CCM administrators need to enable the CISCO-CCM-MIB module in the SNMP agent.

john.caterino Thu, 11/12/2009 - 11:16

Genius!! Only one of the three came back with results and they matched what was in CiscoWorks. Since I am not the CCM admin, is there a box to check that I can request in case the admin is unfamiliar with the setup?

john.caterino Thu, 11/12/2009 - 11:36

No sweat, you have been a huge help!!!!!!

I will confirm that this is the solution and update this thread.

Thanks again!

john.caterino Mon, 11/16/2009 - 12:43

Fix- VOIP system admin found that the two CCMs had an SNMP service that was not enabled. Now seeing phones!

Thank You.

Actions

This Discussion