Configuring QoS for Voip Passthrough

Answered Question
Nov 9th, 2009

Just recently bought a 2811 router to service our WAN sites and prepare us with the implementation of VoIP. We have got Alcatel boxes at the main campus and at the remote site. For the VoIP protocol,Voice traffic will be through RTP that will be transported by UDP. For Qos, we use both TOS and Diffserve, 46. Using G729 codec

The router will not terminate the voice. The Alcatel boxes will be the voice gateways. Just want to apply QoS for the voice traffic that pass through Ethernet and the WAN ports(1841) on remote site and also at the main campus (2811). Got a 1024kbps lease circuit from our telco between main campus and remote site. Just need help in configuring QoS so that I can provide a good voice quality on extension calls (4 to 8 simultaneous calls) between the main campus and the remote site using our lease circuit. Was thinking of Autoqos Voip but I beleive my IOS versions doesn't support that. What is your advice on manual QoS and Autoqos voip ?

IOS Version as follows:

1841 - Remote site


Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(25b), RELEASE SOFTWARE (fc1)

Technical Support:

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Wed 12-Aug-09 10:49 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

ciscoCETC uptime is 21 hours, 13 minutes

System returned to ROM by power-on

System image file is "flash:c1841-ipbase-mz.124-1c.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to

[email protected].

Cisco 1841 (revision 7.0) with 115712K/15360K bytes of memory.

Processor board ID FHK121820Q1

2 FastEthernet interfaces

1 Serial(sync/async) interface

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity disabled.

191K bytes of NVRAM.

31360K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

2811- main campus


Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(15)T9, RELEASE SOFTWARE (fc5)

Technical Support:

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Tue 28-Apr-09 13:10 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)

teika uptime is 6 days, 23 hours, 41 minutes

System returned to ROM by power-on

System image file is "flash:c2800nm-ipbase-mz.124-15.T9.bin"

Cisco 2811 (revision 53.51) with 249856K/12288K bytes of memory.

Processor board ID FHK1339F08U

2 FastEthernet interfaces

4 Serial(sync/async) interfaces

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

I have this problem too.
0 votes
Correct Answer by Joseph W. Doherty about 6 years 11 months ago

"Is that okay ? "

Seems reasonable.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (6 ratings)
Joseph W. Doherty Tue, 11/10/2009 - 05:46

I'm not much of a fan of AutoQoS on routers, although on switches, perhaps.

From what you've described, your most likely point of congestion might be the WAN link. You might want to try a simple QoS policy such as:

(NB: syntax might be incorrect)

class-map match-any real-time

match ip dscp EF

policy-map sample

class real-time

priority percent 33

class class-default


interface serial #

service-policy output sample

tx-ring-limit 2

You might also need to consider QoS on the LAN.

utawakevou Tue, 11/10/2009 - 13:08

Thanks for the response. Can you point me to a document related to this or have an example as this. Need to read up a bit be fore setting this up

Let me know

utawakevou Tue, 11/10/2009 - 15:06

We are also planning to use video conference on this link. Will this sample config be suffice for video conference as well. We are currently using polycom units.

Hope someone helps

Joseph W. Doherty Tue, 11/10/2009 - 18:41

Yes, you would just need to also match against the polycom DSCP markings (and insure you have enough bandwidth - you might not for both). You might want to place video in its own LLQ class.

utawakevou Wed, 11/11/2009 - 14:59

Thanks. I manage to get the docs from cisco site

Thank you once again for your advice

utawakevou Thu, 11/12/2009 - 15:08

I have write up this and want to see if this is fine for 33 percent of traffic for voice, 25 percent for video, 16K for voice signal and the rest for other traffic. Let me know:

class-map match-all video-traffic

match access-group 101

class-map match-all voice-traffic

match access-group 102

class-map match-all voice-signaling

match access-group 103

policy-map voip-video-policy

class video-traffic

priority 25

class voice-traffic

priority 33

set dscp ef

class voice-signaling

bandwidth 16

class class-default


interface Serial0/0/1

description LINK TO CETC-168350

bandwidth 1024

ip address

service-policy output voip-video-policy

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip route-cache flow

access-list 101 permit tcp any any range 3230 3231

access-list 101 permit udp any any range 3230 3235

access-list 102 permit udp any any range 16384 32767

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720

Joseph W. Doherty Thu, 11/12/2009 - 17:06

Recall Cisco suggests not using more than about 1/3 link bandwidth for LLQ. Your video and voice allow up to 58 %(?), so as I commented before, you might have insufficient bandwidth for both. (NB: believe they make this suggestion to allow sufficient bandwidth for other traffic, but also assuming both your VoIP and video is VBR, you also often need to have some cushion of bandwidth for bursts and at close to 60%, you might not have enough burtable bandwidth.)

Although "the book" shows placing signaling within its own class, I've found dropping in within class-default FQ or adding to the voice LLQ also seems to work well.

utawakevou Sun, 11/15/2009 - 16:15

Thanks for your response. Went through a couple of documents and was thinking of giving 9% to Voice i.e 11.2 Kbps per G729 call. So 11.2Kbps x 8 = 89.6Kbps dedicated for voice and on my polycom unit I notice that it is setup to 128K so allocate 128K for Video. Which in total of voice and video is 22% of 1024Kbps. Is that okay ?


This Discussion