MGCP Gateway-two step dialing problem

Unanswered Question
Nov 10th, 2009


My voice gateway is registered on ccm4.2 as an MGCP gateway.

Calls to and from the PSTN are working ok.

The problem is when someone calls into the office,there is 2-step dialing.

The call is supposed to terminate at the receptionist,so when u call our office, in between the first ring and the time the receptionist is able to hear the phone ring and pick the call there is a noise that comes(the noise sounds like a dial tone).

what settings am i missing?this is how the FXO port is configured:


voice-port 3/0/4

cptone KE

timeouts interdigit 4

timeouts call-disconnect 2

timeouts wait-release 2

timing hookflash-out 500


I hope am clear-there is a sound that sounds like a dial tone that one hears when you call our office.

Someone please assist.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Brandon Buffin Tue, 11/10/2009 - 06:37


Make sure that this port is being controlled by Callmanager. You should see a dial peer like:

dial-peer voice 99910 pots

application mgcpapp

port 3/0/4

Also, in CCM admin > Device > Gateway > your gateway > Endpoint config, make sure you have a valid DN entered for Attendant DN.

Hope this helps.


Koiser_Nicholas Tue, 11/10/2009 - 06:52

I have already configured as above,

The attendant DN has also been configured,and hence calls can get to the receptionist.

My only problem is:when you call the office,there is some noise that sounds like a dial tone that the caller hears before the call finally gets to the receptionist.

Hope am clear.


Brandon Buffin Tue, 11/10/2009 - 07:49


Sounds like the attendant DN you have configured overlaps with a route pattern that has "Provide Outside Dial Tone" configured. Go to Route Plan > Route Plan Report and search for the first few digits of the DN.

Hope this helps.



This Discussion