OSPF PPP links /32 subnet "area 0.0.0.0 : src not on the same network"

Unanswered Question
Nov 10th, 2009
User Badges:

Hi to All,


Two PPP router links /32 subnet and the links see OSPF hello packets form each other.


Problem:

The client complaints "Rcv pkt from xxx.x.137.65, Dialer2, area 0.0.0.0 : src not on the same network"


Theory:

as there cannot be more than 1 host on a /32 network, OSPF will always complain that the remote peer is not in the same subnet (OSPF needs both the ends in the same network to form neighbour relationship).


Question:

As the dialer 2 interface has a /32 ip and the interface bound to the virtual-template can't be part of that /32 network what the solution to this would be ?


Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nagendra Kumar ... Tue, 11/10/2009 - 06:10
User Badges:
  • Cisco Employee,

Hi,


From your description, I assume you are running PPPoE with address negotiation via IPCP (using "ip address negotiated" on client dialer interface).


If the above is your case, you need to use DHCP for address negotiation and not PPP, as PPP doesn't have option of mask negotiation and client address always end up with /32 address.


Try "ip address dhcp" on client dialer interface and create a DHCP pool on Server side.


HTH,

Nagendra

ROBERTO TACCON Tue, 11/10/2009 - 06:33
User Badges:

Hi,


thanks for the reply.




I'm using L2TP :


ROUTER 1#

!

interface Loopback0

ip address 192.168.16.51 255.255.255.255

!

interface Tunnel0

description ** backup **

ip address 192.168.18.198 255.255.255.252

ip mtu 1524

tunnel source Loopback0

tunnel destination 192.168.16.1

!

!

interface ATM0

description ** ADSL Internet **

no ip address

ip mtu 1500

load-interval 30

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface BRI0

ip address negotiated

encapsulation ppp

load-interval 30

dialer idle-timeout 180

dialer string 7090811814

dialer-group 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp chap hostname [email protected]

ppp chap password 7 11111111

ppp pap sent-username [email protected] password 7 11111111

!

interface FastEthernet0

ip address 10.4.7.145 255.255.255.240

load-interval 30

speed auto

no cdp enable

!

interface Dialer0

description ** Ip 195.245.55.55 **

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname [email protected]

ppp chap password 7 0019827373705F5D

!

router ospf 50

log-adjacency-changes

redistribute connected subnets

passive-interface BRI0

passive-interface Tunnel0

network 10.10.10.180 0.0.0.3 area 0

!

ROUTER 1#

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

4d06h: OSPF: Rcv pkt from 10.10.12.1, Dialer0, area 0.0.0.0 : src not on the same network

ROUTER 1#

ROUTER 1#




ROUTER 2#

!

interface Loopback1

ip address 10.10.12.1 255.255.255.255

!

!

interface Virtual-Template1

ip unnumbered Loopback1

ip tcp adjust-mss 1300

no peer default ip address

ppp authentication chap

ppp multilink

!

!

vpdn-group 1

! Default L2TP VPDN group

description ** VPDN ADSL SITES **

accept-dialin

protocol l2tp

virtual-template 1

l2tp tunnel password 7 02666664F18050E2D454C1C0B51

!

!

router ospf 50

log-adjacency-changes

no auto-cost

redistribute ospf 129

passive-interface FastEthernet1/0

passive-interface FastEthernet3/0

network 10.0.0.0 0.255.255.255 area 0

network 192.168.16.0 0.0.0.255 area 0

network 192.168.31.160 0.0.0.3 area 0

default-information originate

!



Regards

Nagendra Kumar ... Tue, 11/10/2009 - 07:32
User Badges:
  • Cisco Employee,

Hi,


"ip address negotiated" under dialer interafce will use PPP IPCP for address negotiation. This doesnt have the option to negotiate subnet mask and so will have /32 as subnet on dialer interface. With this, OSPF cannot be enabled.


You may have to try "ip address dhcp" on dialer interface and configure the Server as DHCP server and a DHCP pool with subnet as non /32. This will solve your issue.


HTH,

Nagendra

ROBERTO TACCON Tue, 11/10/2009 - 07:49
User Badges:

As I cannot modify the DHCP configuration are there any other option ?


Regards.

ROBERTO TACCON Wed, 11/11/2009 - 05:47
User Badges:

Please are there any other option: as I cannot modify the DHCP configuration are there any other option ?


Regards


Roberto Taccon

alam Sat, 11/23/2013 - 02:53
User Badges:

Hi,


May I know what IOS are you using? This problem may relay to IOS version.


Regards,

Aqua

Actions

This Discussion