RME 4.0.6 Device Package update failure

Unanswered Question
Nov 10th, 2009
User Badges:

Hi,


i have downloaded a lot of new device packages for the RME 4.0.6. If i install this packages i get the following error message.


Installation failed for product [Resource Manager Essentials] with message : com.cisco.nm.xms.psu.packagemgmt.InstallerException: Repository in use.

Another Package Support Updater client session may be modifying device support.


I searched for the psu.lock file but i couldn't find this file. How can i fix this without reinstalling the lms?


André

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 11/10/2009 - 08:51
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Check NMSROOT/www/classpath/com/cisco/nm/xms/psu for a lock file. If it exists, delete it.

aeggers Tue, 11/10/2009 - 08:59
User Badges:

hi,


there is no lock file. i see that the psu.log is growing and growing, but after some minutes it starts again from 0 kbytes also if i stop the lms daemons ??


andre

Joe Clarke Tue, 11/10/2009 - 09:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

That error can only mean a lock file exists. The only two lock files will be NMSROOT/Psu.Lock or NMSROOT/www/classpath/com/cisco/nm/xms/psu/psu-installer.lock. Post the full psu.log.

aeggers Tue, 11/10/2009 - 23:04
User Badges:

Hi,


i have attached the psu.log file. There is no .lock file, i've checked this again. I tried again to update the device packages


After 1 hour i stopped the update.( normaly an update take max. 10 minutes. During the device package update i could see the the psu.log file was going into a loop. It starts at 0 kbytes -> growing to nearly 950kbytes and than it starts again at 0 kbytes


Andre

Joe Clarke Tue, 11/10/2009 - 23:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Your package repository is corrupt. It needs to be recovered. There is a procedure available by contacting TAC. They will send you a package bundle and steps to recover the repository.

aeggers Tue, 11/10/2009 - 23:11
User Badges:

Hi Joe,


thank you very much. I will open a service request.


Have a nice day.


André

Actions

This Discussion