Music On Hold Problem

Unanswered Question
Nov 10th, 2009

Configuration is SPA9000 + SPA400 + SPA942's, all with latest firmware.

I initially was using just the SPA400 (line 1) for external calls (3 pots lines).  Music on hold worked fine (put a call, either inbound or outbound, on hold using the SPA942 hold button, external caller hears SPA9000 MOH - soothing guitar music).

I then added an ITSP (Nexvortex) on line 2.

When a call comes inbound via the ITSP, can put the caller on hold and they hear MOH.

However, on outbound calls over the ITSP, when a caller is put on hold, they hear nothing.  Then when you press the line key to pick up the held call, the remote end hears a tiny snippet of the MOH before being connected back to the station that picked up the call.

Now here's the interesting thing.  When I use the call park feature instead of the hold button, there is no problem.  External caller can always hear the SPA9000 MOH.

Any ideas?  We need the MOH to work on both directions when using the hold button (our users do not use and do not want to use the park feature).

Thanks for your help!

Mark

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
p.kilkeary Wed, 11/11/2009 - 18:12

Mark,

Sorry to say but I cannot supply any support on this issue, I just was to add that I too am running into Music on Hold issues with a Linksys SPA9000 VoIP solution. My clients are in the same position in reagrds to Call park they are not interested in using that feature. I have configured it with Engin as the ITSP service provider and I am not getting any Music on Hold from external calls irrespective of them being inbound or outbound. Yet I have full Music on Hold capabilites within the network.

The external device I am using is a WaveCube Xstream 5095, I was curious as to what you are using as your MoH server.

Thanks,

Matthew

William Childs Thu, 11/12/2009 - 05:03

Mark,

Would it be possible for you to post your configuration so I can try to replicate your issue? Also, how old is this deployment, and did it ever work as intended?

You can find how to post your config here:

https://www.myciscocommunity.com/docs/DOC-3027

Are you using/wanting to use a streaming audio server (SAS) or the internal MOH?

Bill

markgruber Thu, 11/12/2009 - 11:06

Thanks for looking into this.  I will get the configuration for you.  Right now I am using the internal SPA9000 MOH.    This deployment is a little more than a year old and it did work when I used the SPA400 with PSTN lines.  Since we moved to ITSP VOIP service (nexvortex) it has not worked properly.  Note that we are still using the SPA400 for voicemail.

Mark

markgruber Thu, 02/04/2010 - 18:15

I have solved the problem.  Finally.

I talked with the fine support folks at Nextvortex and they helped me solved this problem.  It was very simple.  They performed a trace while I put a call on hold and noticed that the associated invite contained the ip address 0.0.0.0.  They suggested that I turn off the RFC 2543 Call Hold: parameter on the SIP tab of the SPA9000 under SIP parameters. The default for this parameter was "yes" and I set it to "no".  Note that I needed to do this on each of my SPA9xx phones as well (its on the SIP tab for the phones as well).

Now I get MOH (I use the SPA9000 internal music) for both outbound and inbound calls.

On to my next problem:  After picking up a call that was placed on hold sometimes the audio is lost in the inbound direction.  Very strange.

Thanks to all that helped.

markgruber Thu, 11/12/2009 - 11:02

Right now I am just using the internal SPA9000 MOH capability, no external unit.  Although my client has asked me if I can pull it from a local radio station or online streaming source.  I think the former is doable using an adapter connected to the FXS port.  Not sure how to set up the latter.

From other online posts I have read it seems that this problem may be influenced by the specific ITSP being used.  Mine is nexvortex.

Jack Germanos Mon, 10/28/2013 - 06:12

Hi there I have about 5 clients still on the spa9000 they all use Engin for their SIP services they all have external MOH issues (can not hear the music).

Disabling RFC xxx in the sip tab fixed this are you sure? Is that all you had to do? Why couldn't Cisco advise of this?

Spent days trouble shooting with them I'll give it a try

Sent from Cisco Technical Support iPhone App

Actions

This Discussion