QoS on 2821 for aDSL

Unanswered Question
Nov 11th, 2009

I need help configuring QoS on a Cisco 2821 router. Our Internet connection is an ADSL (6Mb/s DOWN / 768Kb/s UP). There are about 50+ users competing for the bandwidth and we've had many occurances of people downloading large files and causing critical applications to fail.

I've set up QoS on the router (see configuration below), which has help but we still have "run away" applications that cause the ADSL to be completely saturated.

access-list 99 remark Access List 99 for QoS_Level_3

access-list 99 permit

access-list 99 permit

class-map match-any QoS_Level_0

description Non Business Related

match protocol netshow

match protocol rtsp

match protocol vdolive

match protocol winmx

class-map match-any QoS_Level_1

description Busines Business Related - Low Bandwidth

match protocol novadigm

match protocol ntp

match protocol secure-ftp

match protocol tftp

match protocol ftp

class-map match-any QoS_Level_2

description Busines Busines Related - Medium or Spare Bandwidth

match protocol pop3

match protocol http

match protocol secure-http

match protocol irc

match protocol h323

match protocol nntp

match protocol secure-irc

match protocol secure-pop3

match protocol skinny

match protocol ssh

match protocol xwindows

class-map match-any QoS_Level_3

description Business Critical - High Bandwidth

match access-group name TFS

match protocol exchange

match protocol snmp

match protocol ldap

match protocol pop3

match protocol secure-imap

match protocol secure-ldap

match protocol secure-telnet

match protocol smtp

match protocol sqlnet

match protocol sqlserver

match protocol syslog

match protocol telnet

match protocol icmp

match access-group 99

match protocol secure-http

class-map match-any QoS_Level_4

description Business Related - Streaming Multimedia

class-map match-any QoS_Level_5

description Business Related - Interactive Media and Voice

class-map match-any QoS_Level_6

description Layer 3 Network Control Reserved Traffic

match protocol bgp

match protocol dhcp

match protocol dns

match protocol eigrp

match protocol ospf

match protocol rip

class-map match-any QoS_Level_7

description Layer 2 Network Control Reserved Traffic



policy-map QoS_Levels

class QoS_Level_3

bandwidth percent 54

class QoS_Level_0

bandwidth percent 1

class QoS_Level_1

bandwidth percent 5

class QoS_Level_2

bandwidth percent 10

class QoS_Level_4

bandwidth percent 10

class QoS_Level_5

bandwidth percent 10

class QoS_Level_6

bandwidth percent 5

class QoS_Level_7

policy-map QoS_Internet_Access

class class-default

police cir 6000000

conform-action transmit

exceed-action drop

shape average 6000000

service-policy QoS_Levels

interface GigabitEthernet0/0.3

description ASA

bandwidth 6000

encapsulation dot1Q 3

ip address xxxx

ip access-group 111 out

ip accounting output-packets

ip nbar protocol-discovery

service-policy output QoS_Internet_Access

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joseph W. Doherty Wed, 11/11/2009 - 17:21

For outbound, would suggest FQ shaping at 768 Kbps. For inbound, Cisco QoS features don't well support techniques that could best manage inbound congestion. Some 3rd party traffic (TCP) shaping devices can do better.


This Discussion