CME TFTP and Firmware Update Issue

Answered Question
Nov 12th, 2009
User Badges:

I've got CME on a 2821 Integrated Services Router, and a bunch of 7921G wireless phones. They will register with the 1.2.1 firmware that was originally loaded, but I'm trying to update to 1.3.3 and also to add some custom ringtones, and they are generating some errors when I reset them:


-04:49:34p CFG File Not Found

-04:49:34p XMLDefault.cnf.xml: TFTP Error

-04:49:34p SEPMACADDRESS.cnf.xml: TFTP Error


The files for the firmware were uploaded to the router's FLASH: (along with my ringtone files).


I ran the tftp-server commands via telnet.


I ran the "load 7921 CP7921G-1.3.3" from telephony-service. I also ran the "no create cnf-files" and then ran "create cnf-files" commands based on another thread I found here.


Then I restarted a few of the phones and they all trigger the same result.


I know I'm missing something (and it's probably simple), but any ideas on how to proceed?

Correct Answer by paolo bevilacqua about 7 years 7 months ago

If you have a cisco AP, recommend you use a separated SSID/VLAN for voice.


This way, you will not depend by an external DHCP server, and all your phones will be in the same VLAN.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Brandon Svec Thu, 11/12/2009 - 16:33
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Small Business, February 2016

Have you turned on debug tftp events? This should give you a good clue of what the phones are looking for.

muranskycotech Fri, 11/13/2009 - 05:41
User Badges:

I just did, and when I "show log" after rebooting the phone all I see is the usual registration attempt. Is there something special I need to do in order to see the TFTP log?

Brandon Svec Fri, 11/13/2009 - 09:36
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Small Business, February 2016

I don't think so. Are your phones using the router for their tftp server?

paolo bevilacqua Fri, 11/13/2009 - 09:39
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes, "term mon".

Brandon Svec Fri, 11/13/2009 - 09:43
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Small Business, February 2016

Good catch Paolo ;)

muranskycotech Fri, 11/13/2009 - 09:57
User Badges:

Well I tried term mon before and after the show log, but to no difference. So let me post my config file and let you guys snoop through it for any clues.


I stripped out the lines with passwords and usernames, but it's otherwise in tact.


Forgive me guys, I'm still extremely new to this, so I know it's going to be something simple... I'm just not experienced enough yet to know what I'm missing. And thank you for the assistance!



Attachment: 
muranskycotech Mon, 11/16/2009 - 08:14
User Badges:

A quick update on this... I attempted to connect to the TFTP server from my laptop, and I am getting a timeout on the connection-- Connect request failed. This leads me to believe that despite the configuration, the service isn't really running.


Based on the config I posted, any advice on how to get the TFTP server to respond properly?

muranskycotech Mon, 11/16/2009 - 10:02
User Badges:

OK, so it took a whole lot of searching to find the right tip, but I found the solution!


Basically, I eventually discovered that DHCP wasn't assigning the TFTP server for the phones after stumbling across a post that wanted to use their own TFTP server instead of the router.


Now, in my router config, I do have the appropriate options 150 parameter in place, but I ended up not using that pool and have been using one created on my LAN DHCP server instead. I didn't set option 150 there. As soon as I set it and rebooted the phone, the downloads began immediately.


BTW, Windows DHCP servers don't have an option 150, so you have to create it yourself. To do this, go to DHCP Manager, right click on the server, and choose "Set Predefined Options". Add 150 with an IP Address type, and then you can add that option to your scope.


Anyway, problem is solved!

Correct Answer
paolo bevilacqua Mon, 11/16/2009 - 10:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

If you have a cisco AP, recommend you use a separated SSID/VLAN for voice.


This way, you will not depend by an external DHCP server, and all your phones will be in the same VLAN.

muranskycotech Mon, 11/16/2009 - 10:23
User Badges:

We already do keep everything on a separate VLAN, but I purposely want all of my DHCP handled by my DHCP servers not by the routers and other boxes.

Actions

This Discussion