SCCP MTP registration issue with CUCM 6.14

Unanswered Question
Nov 12th, 2009
User Badges:
  • Green, 3000 points or more

I have the following:


(3) DSP 64 chips

(1) PRI

(1) FXS 4/did card


There is something goofy with this new "Version" on SCCP commands.


If I use version 3.1 on my SCCP, My CFB and xcode works fine, but my MTP will not register.


If switch to Version 6.0 for SCCP, my MTP, but then CFB and xcode will not register.


12.4(22)T2 is on the router.


Its a basic config.


sccp local Loopback0

sccp ccm XXX.XXX.XXX.XXX identifier 2 version 3.1

sccp ccm XXX.XXX.XXX.XXX identifier 1 version 3.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register FRE11_XCDR

associate profile 2 register FRE11_CFB

associate profile 3 register FRE11_MTP

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 8

associate application SCCP

!

dspfarm profile 2 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP


dspfarm profile 3 mtp

description Media Termination Point

codec g711ulaw

maximum sessions hardware 8

associate application SCCP


I hunted the bugs, cant find anything.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Fri, 11/13/2009 - 18:59
User Badges:
  • Green, 3000 points or more

Ok, can anyone tell me why this configuration works? notice the versions are different for MTP and xcode and transcode CCM? But this is the only way I could get it to work??


sccp local Loopback0

sccp ccm 172.19.20.10 identifier 2 version 6.0

sccp ccm 172.19.20.11 identifier 1 version 3.1

sccp

!

sccp ccm group 2

associate ccm 2 priority 2

associate profile 3 register FRE11_MTP

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 2 register FRE11_CFB

associate profile 1 register FRE11_XCDR

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 9

associate application SCCP

!

dspfarm profile 2 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

dspfarm profile 3 mtp

description Media Termination Point

codec g711ulaw

maximum sessions software 100

associate application SCCP


Tommer Catlin Fri, 11/13/2009 - 19:48
User Badges:
  • Green, 3000 points or more

I love a thread I an answer myself, that I started.


So...... After CUCM 5.x, it only uses Enhanced for Transcoders and Conference bridges.


MTP by default uses Enhanced, no other option.


So when I configured SCCP Version 3.1 with standard bridge and xcoder, it worked fine.


But in SCCP 3.1, MTP was not introduced yet in CUCM.


This is why MTP worked with 7.0 or 6.0 or whatever.


So, changed the bridges and xcoders to enhanced, then changed my versions in SCCP to 6.0 and everything worked.


It throws you off because 3.1 actually works fine with standard in CUCM. but if you require MTP, everything has to be enhanced.


Enjoy

Actions

This Discussion