Router on a stick question

Unanswered Question
Nov 13th, 2009

Hi,


I have to configure a Cisco 1841 router and a Cisco 3500-XL-EN switch to send out to a remote office. I need to use the routers ethernet interface as an 802.1q trunk so that I can create and route to two vlans on the 3500 switch.


Simple configuration correct?


Regards

JK

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jskrawczyk Fri, 11/13/2009 - 06:27

Hi Jon and thanks.


I read through the configuration document and now I need to ask if I setup DHCP on my router will it send out IP addresses to the appropriate VLAN?


Regards

Jeff


Jon Marshall Fri, 11/13/2009 - 07:31

Jeff


Yes it should do as the router will know which subinterface the DHCP request came in on.


Jon

jskrawczyk Fri, 11/13/2009 - 07:36

Jon,


Do you have experience with Voip? Looking at interface fa0/2, I need my users to connect to VLAN1 and my shoretel Voip users to drop into VLAN24.


Do you know if this will work?


Regards

Jeff


My Cisco switch in summary is like this:

SWITCH CONFIGURATION

vlan database

vtp transparent

vlan 24

exit

!

interface FastEthernet0/1 (Connect to router)

switchport trunk encapsulation dot1q

switchport mode trunk

no shutdown


interface FastEthernet0/2

switchport voice vlan 24

spanning-tree portfast

no shutdown

!



Jon Marshall Fri, 11/13/2009 - 07:40

Jeff


You have lost me here, what has this to do with routing on a stick ?. If you have a separate interface on the router for vlan 24 then just connect that interface to the switch with the switchport in vlan 24.


Jon

jskrawczyk Fri, 11/13/2009 - 07:46

Sorry for the confusion Jon. I'm okay with the router portion. On another topic, on my layer 2 switch, I will be connecting voice sets, new to me.


On the layer 2 switch, users will connect to any switch port. The user needs to become a member of vlan1 and the IP phone I need to pickup a vlan24 IP. I think the only question I have is should all the switch ports be set to trunk. I would assume.


Thanks for your help Jon!


Regards

Jeff


Actions

This Discussion