CADLink.exe problem

Unanswered Question
Nov 13th, 2009
User Badges:

Hi,


I've installed Cisco Unified CallConnector for Microsoft Dynamics CRM 4 on both side server and the agent machine. Every thing is OK when I seach an account from the Callconnector Client on the agent machine, but when I use CADLink.exe on the IPCC express workflow, it shows the message "No valid search String (see administrator)".


I tried to run CADlink.exe from the DOS prompt like this :


CADLink.exe 11/13/2009 cisco


I have the same error message :


"No valid search String (see administrator)"


Can you help me


Thanks



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Mustapha Arakji Tue, 07/06/2010 - 02:19
User Badges:

Hi,


I'm facing the same issue. Did you manage to find a solution for that?

I think that the parameter is not send to the Connector.


Thanks,

Hythim Ali El Hadad Thu, 09/16/2010 - 10:19
User Badges:
  • Silver, 250 points or more

Kindly I'm finding the below error:



Error Launching Application


Action Name: DoRinging

Application: C:\Program

Error Message: The system cannot find the file specified



And when finishing the call:


The same error appear but with the Action Name: DoDropping



Although I have the following status:

1- The CAD is receiving the caller id for the received contact

2- I can search for this contact in the call connector client installed in the agent PC with the same received caller id and it get the customer information to me


So I'm expecting the CAD link should act as an intermediary between both

But it doesn't happen and the CAD inform that it can't launch the application that I have configured in the desktop admin



Although I have configured it as stated in the installation guide



Please help me in this issue



Thanks

Mustapha Arakji Thu, 09/16/2010 - 23:04
User Badges:

Hi Haytham,


I'm assuming that you're using this guide to integrate CRM connector with UCCX:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucallconnectors/UCC_for_MS_CRM/Rel_212/configuration/guide/CRMinteg.html#wp435992



What i can see from your error message is that the UCCX is tryting to call the CRM application, but it can't find the file, that's cause the link is not correct, you have to specify the full path that points to the CADLink.exe. You will find this in the guide above.


HTH.

Hythim Ali El Hadad Sat, 09/18/2010 - 06:56
User Badges:
  • Silver, 250 points or more

Hi Mustapha,


Thanks a lot for your reply

Kindly I have followed the link and made all requirments as it mentioned


Only I need to inform you about these points if you find it normal for my problem:


1- I'm using CME with the UCCX

2- Only on the client machine, I have installed .net framework version 2 then I have installed the client after that

3- After the installation, I found an application file called CADLink and when double click it, it open a window like visual basic and nothing happen

4- I have copied the path to the Applications filed, as "C:\Program Files\Cisco Systems Inc\CCCClient\CADLink.exe" that it is the path to this CADLink application file


5- In my  network: the agent PC can ping the IPCC server and the CRM server, But the IPCC server can't ping the CRM server that they are in a different network. Is this will affect the application to work ? I think when the call come in, the CAD display the caller ID, then the agent PC it self should pass it to the CRM client using the CADLink to search the CRM database, So I think it might not affect my CRM client



Thanks a lot for your help and awaiting for your feedback to have this issue solved

Hythim Ali El Hadad Sun, 09/19/2010 - 12:06
User Badges:
  • Silver, 250 points or more

Dear All,


Kindly if some one has dealed with it before

Please check the below log

the first section is when a received call with ANI: 0181234567 , and it appear at the crm connector client as inbound: 0181234567

But told no search result

So now the CAD send the ANI to the call connector but it come with no search results


The second section is when searching manually with the mobile number 0181234567

The CRM page open automatically with the contact page detail


I have modified a lot in the page of the PNP but with no success at all


So please help me in letting the call connector open the contact page while receiving a call depending on the ANI



2010-09-19T18:31:32     C4CLIENT     INFO-00000500     CADLink Received notification of new call: callId=71129600; ANI/DNIS=0181234567
2010-09-19T18:31:32     C4CLIENT     INFO-00000401     Passing New Phone Lookup command to Lookup Plugin: pNum=0181234567; IsInbound=True
2010-09-19T18:31:32     CRMPLUGI     INFO-0000a200     Received NewCall notification: WindowId=71129600; CallId=71129600
2010-09-19T18:31:32     CRMPLUGI     INFO-0000a11a     Processing Phone Number for Search: '0181234567'
2010-09-19T18:31:32          PNP     INFO-0000a000     Processing phone number: phoneNumStr=0181234567
2010-09-19T18:31:32          PNP      DBG-0000a001     Result of prefilter: 0181234567
2010-09-19T18:31:32          PNP      DBG-0000a002     DigitsOnly: 0181234567
2010-09-19T18:31:32          PNP     INFO-0000a008     PNPResults: DialTarget=Unknown; DialString=0181234567; CC=; AC=; EX=; ST=; EXT=; SN=;
2010-09-19T18:31:32     CRMPLUGI     INFO-0000a11b     ProcessPhoneNumber Returned 0 results
2010-09-19T18:31:45     C4CLIENT     INFO-00000501     CADLink Received call status change: callId=71129600; Status=disconnected
2010-09-19T18:31:45     CRMPLUGI     INFO-0000a202     Received Call Termination notification: CallId=71129600
2010-09-19T18:31:45     CRMPLUGI     WARN-0000a116     No phone activity Guids were created for callId=71129600 has no phone activity guid - can't create note
2010-09-19T18:31:45     CRMPLUGI     INFO-0000a202     Received Call Termination notification: CallId=71129600
2010-09-19T18:31:45     CRMPLUGI     WARN-0000a114     Couldn't find active call with callId=71129600 to terminate - can't create note





2010-09-19T18:34:40     C4CLIENT     INFO-00000405     Passing New Text Lookup command to Lookup Plugin: sText=%0181234567%
2010-09-19T18:34:40     CRMPLUGI     INFO-0000a201     Received New Search notification: WindowId=1256719514; SearchText=%0181234567%
2010-09-19T18:34:40     CRMPLUGI     INFO-0000a300     Starting CRM Search: searchText='%0181234567%'; isPhoneNum=False; extradigits=; bAllowCache=False
2010-09-19T18:34:40     CRMPLUGI     INFO-0000a301     CRM Search produced 1 results
2010-09-19T18:34:40     CRMPLUGI      DBG-0000a302     CRMSearchResult: DisplayName='mohamed nabil'; EntityName=account; ObjectType=Account; ObjectId=06a0c80e-98c1-df11-a345-002481e1fe22
2010-09-19T18:34:40     LUCOMMON       ON-7fffffe4     Results: 1 match; bEnableClientIPPhonePush=False; EnableIPPhonePush=False





Thanks & Best Regards

Mustapha Arakji Fri, 09/24/2010 - 05:35
User Badges:

Hi,


In the PNP (Phone Number Processor Configuration) there's a Pattern Recognizers on the right side, you should have some patterns there.


In the Search Formats below, this is what the CRM connecter try to search based on these formats, so i would suggest to use an internal extension first, don't try an outside call.
For example, use the "%{ext}%".
After you do this, you should test your pattern in the Pattern Testing area above the Search Formats, fill the extension and press Test, the result should should show you if the number you entered does match a pattern.


Regards,

Actions

This Discussion