Auto Attendant submenus not recognizing keystrokes from outside

Unanswered Question
Nov 13th, 2009
User Badges:

Hi everyone,


I am having a problem where my auto attendant has mutiple submenus , and once getting past the main menu (which reconizes), anything that goes to those submenus while calling in from outside (not internally), the keystrokes are not recognized?  any idea?


I am on a SIP provider if it makes any difference



Thanks

Dom

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dlandriscina Mon, 11/16/2009 - 06:11
User Badges:

I seem to have narrowed down the problem to the voice service voip, supplementary-service sip refer.  It needs to be negated for the AA to work properly however, a few weeks ago,  I needed to enable it to allow interoffice transfers via Multisite from outside SIP callers.   Steve DiStefano was helping me on this.  Any way of getting in touch with him?


Thanks

Steven DiStefano Mon, 11/16/2009 - 06:25
User Badges:
  • Blue, 1500 points or more

Whats cooking guys?


tell me the problem and I'll see how we can help....


Steve

dlandriscina Mon, 11/16/2009 - 13:11
User Badges:

Hey Steve,


I am at that site in Brooklyn again , thanks for your help last time!


I am encountering a problem that when i have the supplementary service sip refer on, it is not recognizing keystrokes in my auto attendants additonal submenus.



Also , I had 3 other questions :


1) Is it possible to hear paging while on a phone call?


2) Random calls seem to get dropped when in queue on the B-ACD, so i had to convert to a blast group but it doesnt seem to working out for me , i'd like to go back to the B-ACD, but am concerned about the dropped calls. Can you help with this


3) is it possible for B-ACD to ring as a blast config instead of the hunt group options ringing the phones basically in a circle?


Thanks so much ,


Domenick

Steven DiStefano Mon, 11/16/2009 - 14:20
User Badges:
  • Blue, 1500 points or more

BACD:

What version of TCL scripts are you running on your UC500?

There was known (bad behavior that I would call random failures) in the early release 2.x.x.x and so we went to 3.0.0.2.  Please check this first.

https://supportforums.cisco.com/docs/DOC-9731


The CCA 2.x will automatically configure (tftp) the correct scripts to flash for you provided you are running a recent release (at least 7.0.3) and you have the directory sub-directory structure on your flash.

https://supportforums.cisco.com/docs/DOC-9721


The BACD hunt group algorithms  include:

  • Sequential: Calls are routed to Basic ACD hunt  group members in the order they are listed in the Members  dialog.

  • Peer: Calls are routed to Basic ACD hunt group  members in round-robin order (circular).

  • longest-idle: Calls are routed to the member of the  BACD hunt group with the longest idle time.


PAGING:

If on a call Paging wont alert your line.

If you get paged and then a call comes in, you can answer it.

dlandriscina Mon, 11/16/2009 - 14:33
User Badges:

Hey,


I am in fact using the tcl script 3.0.0.2  (the other scripts still seem to be in the directory however, do they need to be deleted), the config specifies to use the new ones also, so any other reason why calls would be randomly dropping?



Regarding the hunting algorithm :  is there any plans for the future for it to support ringing all of the phones at once, the problem i have is that, when the calls are in queue.  The other phone operators have to wait for the call to circle back to them to pick it up and takes time.  is there anyway to access the calls in queue without having to wait until it circles back to them?


Thanks!

Steven DiStefano Mon, 11/16/2009 - 14:41
User Badges:
  • Blue, 1500 points or more

Hi,

Nope, you should not be dropping any calls.  3.0.0.2 works very well and have no cases indicating otherwise.


You can shorten the queue time and retry timers....


Steve

dlandriscina Mon, 11/16/2009 - 14:58
User Badges:

Ok , i will try them out again.  Do you have any idea why the supplementary service sip refer would be affecting the Auto Attendant in the above mentioned posts?


thanks

Steven DiStefano Tue, 11/17/2009 - 13:42
User Badges:
  • Blue, 1500 points or more

Hi Dom,

Ok so if you use CCA 2.1 to configure your multisite (the new Multisite manager inside CCA), it will configure your system to make H.323 extension calls since these will support Video across sites.  Pure SIP wont.   This is just between the sites.  You can still have a SIP trunk call terminate into one UC500 and get transferred to the other using extension dialing and that leg would be H.323.


So the two commands:

no supplementary-service sip moved-temporarily
no  supplementary-service sip refer


..may be superfulous.


I built a 2 site MS with CCA 2.1:

https://supportforums.cisco.com/docs/DOC-9775


..and am making calls between the two, and dropping voice mail and it works!  But I dont have a SIP trunk on my multisite machine so cant test your exact scenario, which I believe is Ingress SIP transferred to the other site and hits AA and then cant enter DTMF.


But my site 2 config looks like this (this one was from factory reset and used TSW to change his data VLAN, before running MS Manager):
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
sip
  no update-callerid


Here is Site 1.  No factory reset.  Upgraded to UC520-7.1.3ea but left running config as it was.  Then ran MS manager.


voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
sip    
  no update-callerid



So who is the SIP Provider and how did you configure it on yor UC500?

How did you configure your multisite?  R U using SIP or H323 for intersite extension calling (Look at your dial peers and translation rules and compare to this (I have one pade SIP intersite (no video) and 1 page of H323 intersite)?

https://supportforums.cisco.com/docs/DOC-9488


Then we can see how we can help further.....


Steve

dlandriscina Mon, 11/23/2009 - 10:12
User Badges:

Steve,


sorry about the response time.. took me a little while to get back to this site.


Basically here is my configuration : 2 sites configured with MS Manager, working fine.   If you remember some time back I had wrote you regarding transferring a SIP originated call to the other site dropping.  you instructed me to run the sip supplementary service refer on it.  Since then everything was working fine at Site B.


How ever , site A has a different scenario (it has a multiple submenu AA).  Once it gets past the first submenu, it will not recognize keystrokes if supplementary-service sip refer is enabled.  (which is needed for multisite transfered calls originated from sip to work).  I am going to paste the voice service config and dial peers let me know what you think.


I am running 7.0.3 at both sites



Site A (multisite submenu) - keystrokes not working getting past first menu if sip refer is enabled


voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer


dial-peer voice 2100 voip
corlist incoming call-internal
description **CCA*INTERSITE inbound call to AVE-X
translation-profile incoming multisiteInbound
voice-class h323 1
incoming called-number 81[1-9]..
dtmf-relay h245-alphanumeric
codec g711ulaw
fax protocol cisco
no vad
!
dial-peer voice 2101 voip
corlist incoming call-internal
description **CCA*INTERSITE outbound calls to 57ST
translation-profile outgoing multisiteOutbound
destination-pattern 82[1-9]..
voice-class h323 1
session target ipv4:10.10.20.1
dtmf-relay h245-alphanumeric
codec g711ulaw
fax protocol cisco
no vad


SITE B - (Currently working fine with Single Menu AA + transferring sip calls intersite)


voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
no supplementary-service sip moved-temporarily
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
sip
  registrar server expires max 3600 min 3600
  no update-callerid


dial-peer voice 2100 voip
corlist incoming call-internal
description **CCA*INTERSITE inbound call to 57ST
translation-profile incoming multisiteInbound
voice-class h323 1
incoming called-number 82[1-9]..
dtmf-relay h245-alphanumeric
codec g711ulaw
fax protocol cisco
no vad
!
dial-peer voice 2101 voip
corlist incoming call-internal
description **CCA*INTERSITE outbound calls to AVE-X
translation-profile outgoing multisiteOutbound
destination-pattern 81[1-9]..
voice-class h323 1
session target ipv4:10.10.10.1
dtmf-relay h245-alphanumeric
codec g711ulaw
fax protocol cisco
no vad
!


thanks very much!

Maulik Shah Wed, 11/25/2009 - 10:26
User Badges:
  • Silver, 250 points or more

For clarity:


1. Call transfers failing for call from SIP trunk to site A then transfer to site B - is this the issue you had earlier? You set this up via CCA MSM and this fails unless you do the below on site B & site A:


voice service voip

supplementary-service sip refer


Is that accurate? If so I think something is amiss here as you should not need that CLI for inter site transfers. If you have VOIP logs from both sites for such a call would be great.


2. Not able to enter DTMF on 2 level AA on site A if you add below CLI


voice service voip

    supplementary-service sip refer


I think this is expected - you need to disable the REFER so lets fix #1.


A TAC case may also help in narrowing down 1 for quicker feedback as its real time troubleshooting.

dlandriscina Wed, 11/25/2009 - 12:39
User Badges:

Maulik,


Thank you for writing me back.


Here is my dillema:


The problem is, to have incoming SIP calls to be transferred properly between both sites,  supplementary service sip refer needs to be enabled, as both you and Steve stated.


BUT


If that is enabled, then my auto attendant does not recognize keystrokes past my first submenu.


So its either I have it disabled and I get my auto attendant, or i have it enabled and i can transfer calls (incoming SIP) between sites.  I need both to work.


Thanks,

Domenick

Maulik Shah Tue, 12/08/2009 - 16:55
User Badges:
  • Silver, 250 points or more

For inter site calls recommend to use H.323, not SIP and hence the need for enabling "supplementary-service sip refer" is eliminated. The CCA 2.1 or higher release has a Multi Site Manager that allows you to network multiple UC500s using H.323. Have you tried using that at all?

dlandriscina Thu, 12/10/2009 - 09:56
User Badges:

Maulik,


The setup was made using multisite manager, the config is posted above and does note that it using h323 to transfer calls intersite. it still was not working properly thats why Steve had instructed me to enable the sip refer.


Thanks

Maulik Shah Sun, 12/13/2009 - 22:24
User Badges:
  • Silver, 250 points or more

So for the case of AA submenu not recognizing DTMF on site A - is the call flow:


PSTN -- SIP Trunk -- Site A UC500 -- CUE AA on Site A


You can enter DTMF for the 1st menu but nothing beyond that - yes? If so can you change the config on site A to below:


voice service voip

   no supplementary-service sip refer


Enable the troubleshooting log on CCA for SIP calls (check section 5.3 here - https://www.myciscocommunity.com/docs/DOC-10787). Make one failed call and then hit Generate log.


Also would need you to gather below:

Monitor > Reports > IOS Exec commands > show run, then capture the output to a text file

MOnitor > Reports > CUE Exec commands > show ccn subsystem sip, then capture the output to a text file

dlandriscina Mon, 12/14/2009 - 08:08
User Badges:

Maulik -


that command is already in the config - that is why the AA is currently working.


BUT to send SIP calls originated from SITE A to SITE B via intersite transferring,  it needs to be negated or the party at site B will not hear anything. This is the entire issue im running into.

Maulik Shah Mon, 12/14/2009 - 08:30
User Badges:
  • Silver, 250 points or more

So in the case where:


voice service voip

  no supplementary-service sip refer


is on site A - can you make a call from PSTN > SIP Trunk > Site A > transfer to Site B extension and gather the VOIP troubleshooting logs on both UC500s (if using CLI the debugs would be enable all:


deb ccsip message

deb voip ccapi inout

deb h225 q931

deb h225 asn

deb h245 asn


along with the configs at both UC500s

Actions

This Discussion