Virtual Adapter

Unanswered Question
Nov 14th, 2009

Work install VPN Client 5.0.03.0560 in my laptop and it worked once and now it is coming back with Failure to enable Virtual Adapter. Any suggestions of why and how to fix it?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mopaul Sat, 11/14/2009 - 21:04

Hi ,

"Reason 442: failed to enable virtual adapter" error.

Is it the complete error message you are seeing there while making a connection ?

Are you on Vista ?

If you just said YES , then this may be you are running into...

The Reason 442: failed to enable virtual adapter error appears after Vista reports that a duplicate IP address is detected. Subsequent connections fail with the same message, but Vista does not report that a duplicate IP address is detected.

To work around error 442, do the following steps:

Step 1 Open "Network and Sharing Center".

Step 2 Select "Manage Network Connections".

Step 3 Enable the Virtual Adapter ("VA"-Cisco VPN Adapter).

Step 4 Right-click on Cisco VPN Adapter and select "Diagnose" from the context menu.

Step 5 Select "Reset the network adapter Local Area Connection X".

Step 6 Windows will again prompt you saying the IP configuration is still invalid, ignore this and just press Cancel.

Step 7 Go back to the Network Connections, right-click your VPN Virtual Adapter and Disable.

Step 8 Now open Cisco VPN, and you should be able to connect without any issues.

The problem will reoccur every time the connection is not cleanly closed - i.e. suspend / hibernate / loss of signal.

---------------

If this procedure does not work, run the following command from cmd:

reg add HKLM\System\CurrentControlSet\Services\Tcpip\Parameters /v ArpRetryCount /t REG_DWORD /d 0 /f

Then reboot.

This resolves the issue until Vista reports a duplicate IP address again. Follow the preceding steps to resolve it again.

If that doesn't work, you might have UAC enabled.

If so, you must run cmd as administrator and repeat the previous registry workaround (CSCsi26106, CSCsl57566).

Though these caveats are fixed in the version you are running i.e 5.0.03 but still we may suspect.

Vista introduces a new feature called "Receive Window Auto-Tuning". What it does is to adjust the receive windows size continually based upon the changing network conditions.

Some people reported that auto-tuning cause network time-out problems with some applications and routers. You can turn it off if you have experienced such problems.

Open up an elevated command prompt.

Enter the following command to disable auto-tuning netsh interface tcp set global autotuninglevel=disabled If you found that this doesn't fix your problem, you can turn it back on.

Open up an elevated command prompt.

Enter the following command to enable auto-tuning netsh interface tcp set global autotuninglevel=normal You can use this command to view the states of the TCP global paremeters.

netsh interface tcp show global

--- Additional Note: Uninstalling the Microsoft Network Monitor has proven to fix the issue in one instance

As a last test , i would suggest to upgrade your Ipsec VPN client to latest version 5.0.06.0110 .

Or download the client from the link below using your CCO id.

http://tools.cisco.com/support/downloads/go/Redirect.x?mdfid=268438162

Hope this helps.

P.S: I would like to have your feedback on the above mentioned troubleshooting steps for my future troubleshooting references.

Regards

M

Denverken Sun, 11/15/2009 - 21:04

Thank you very much. I'm going to have to contact our IT department because my Cisco VPN connection is not there any more. I will let you know once I get them to install that connection back in my computer.

Actions

This Discussion