Catalyst 3500XL switch port settings for VoIP

Unanswered Question
Nov 16th, 2009
User Badges:

Hi,


I need to setup a Catalyst 3500XL switch to support VoIP phones. Please look at a snippet of my config:

Fa0/1 will connect to my Cisco router setup as a router on a stick.

Fa0.2 will connect to my shoretel Voip Switch

and all remaining ports will be configured to connect to a Shoretel IP phone and the PC will connect off of the Shoretel Phone set.


VLAN1 is the native for PC users and VLAN24 is for VoIP traffic.


Does this look okay?


Regards

Jeff




interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

description Connected to Shoretel switch

switchport access vlan 24

spanning-tree portfast

!

interface FastEthernet0/3

switchport priority default 1

switchport voice vlan 24

spanning-tree portfast


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Svec Mon, 11/16/2009 - 11:08
User Badges:
  • Silver, 250 points or more
  • Community Spotlight Award,

    Small Business, February 2016

This may work if you don't need computers behind the phones.

For that you will need something more like this for your phone/PC ports:


switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 1

switchport access vlan 24


Then you will need to either manually program all the Shoretel phones to use VLAN 24 and pass native VLAN through switchport or find a way to do this via DHCP.



jskrawczyk Mon, 11/16/2009 - 11:13
User Badges:

You are correct. I configured and this is working correctly.


interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport priority default 1

switchport voice vlan 24

spanning-tree portfast

!


Thank you

Jeff



Actions

This Discussion