cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1255
Views
0
Helpful
2
Replies

Catalyst 3500XL switch port settings for VoIP

jskrawczyk
Level 1
Level 1

Hi,

I need to setup a Catalyst 3500XL switch to support VoIP phones. Please look at a snippet of my config:

Fa0/1 will connect to my Cisco router setup as a router on a stick.

Fa0.2 will connect to my shoretel Voip Switch

and all remaining ports will be configured to connect to a Shoretel IP phone and the PC will connect off of the Shoretel Phone set.

VLAN1 is the native for PC users and VLAN24 is for VoIP traffic.

Does this look okay?

Regards

Jeff

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

description Connected to Shoretel switch

switchport access vlan 24

spanning-tree portfast

!

interface FastEthernet0/3

switchport priority default 1

switchport voice vlan 24

spanning-tree portfast

2 Replies 2

Brandon Svec
Level 7
Level 7

This may work if you don't need computers behind the phones.

For that you will need something more like this for your phone/PC ports:

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 1

switchport access vlan 24

Then you will need to either manually program all the Shoretel phones to use VLAN 24 and pass native VLAN through switchport or find a way to do this via DHCP.

-- please remember to rate and mark answered helpful posts --

You are correct. I configured and this is working correctly.

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport priority default 1

switchport voice vlan 24

spanning-tree portfast

!

Thank you

Jeff

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: