How to disable Telnet on a switch

Unanswered Question
Nov 16th, 2009
User Badges:

I would like to disable Telnet on a Cisco 3560G switch. I have seen all over the web that the way to it is by:


line vty 0 4

transport input ssh


However, this doesn't work for me. SSH is not a valid transport on my switch. The only allowable transports are "All", "None" or "telnet". If I try SSH it gives the invalid input error.


I'm assuming this is because SSH is defaulted on Catalyst switches, but how can I remove Telnet?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 11/16/2009 - 12:39
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Well you can use "transport input none" but be aware that you then can't remotely access the switch.


The reason SSH is not an option is probably because you need an IOS version that supports SSH for your switch.


Jon

king06aaa Mon, 11/16/2009 - 12:57
User Badges:

SSH is enabled on the switch. That's what I use all of the time. I'm afraid that if I use "none" I won't be able to access it with SSH then. Is that correct?

Jon Marshall Mon, 11/16/2009 - 13:01
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Steve


Oops, sorry i misunderstood your original post. Yes, definitely do not use "transport input none" as this will indeed lock you out of the switch.


Which IOS version are you running on the switch ?


Jon

Actions

This Discussion