Cisco Aironet 1130AG + iPhone

Unanswered Question
Nov 16th, 2009
User Badges:

Hi,


We have 4 1130's on each floor, and keep getting complaints from iphone users. They claim that although they have a strong signal, when they try to go to the internet, it doesn't work. Anyone ran into issues with iphone connectivity? Anything in the settings that can be optimized for the iphone?


Thanks



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Loading.
bunderberg Thu, 11/19/2009 - 20:41
User Badges:

I am also having the same issue with the Aironet 1200, Iphone users can connect to the WLAN without issue but have no actual connectivity, error on the iphone browser is "Server stopped responding"


Iphone is the latest generation with latest firmware, device shows in the Aironet 1200 web interface as "unknown device" (like other working devices) ping test has success but link test sadly does not.


Have tried almost all settings on the phone to no avail and our Access Point is setup pretty basic, have never had any issues previously with a variety of phones and laptops. AP details below but my guess is its some random setting i am missing;


Product/Model Number:AIR-AP1232AG-N-K9
Top Assembly Serial Number:FHK0905J16C
System Software Filename:c1200-k9w7-tar.123-2.JA
System Software Version:12.3(2)JA
Bootloader Version:12.2(8)JA
isalem Fri, 11/20/2009 - 13:27
User Badges:

I wonder if it's the code, I think I am running the same version.

pierre.xavier2 Thu, 02/24/2011 - 23:31
User Badges:

Hi All,

DId you have any solution for that matters. I have an Access point Aironet 1130 AG, all my devices are working expect the IPHONES....


I already input the "no dot11 extension aironet" command, but it didn't solve anything ...


Thanks for your help.

Pierre    

Leo Laohoo Fri, 02/25/2011 - 00:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I got 1230, 1240, 1250, 1140 and 3500 autonomous AND CAPWAP.  Works well with iPhones, iTouch and iPad.


Test with NO authentication first before piling on all the encryption, security, AAA, etc.

pierre.xavier2 Sun, 02/27/2011 - 23:16
User Badges:

Hi Leolaohoo,

Can you let me know which version of IOS are you running ?
Thanks,

Pierre    

pierre.xavier2 Thu, 03/03/2011 - 01:10
User Badges:

I finally find the root cause of my problem. The Iphones can't support TKIP while AES-CCMP works like a charm.
Conclusion, Apple suc....


Pierre

dmantill Thu, 03/03/2011 - 22:01
User Badges:
  • Silver, 250 points or more

Isalem


Basically it is a client side issue (iphone) and there are some recommendation for that.

Basically keep the configuration as simple as possible. (use guest mode, no AES and TKIP as ciphers, no advance features, no Aironet extensions etc... )

Share with us the configuration if you think is OK with you.

Additionally I recommend you to check this link http://tinyurl.com/4mxmzqo

Even thought it is focus to unified wireless networks (WLC) there are some good tips for this issue.

Rusty Haferkamp Fri, 08/26/2011 - 07:52
User Badges:

I am having a similar issue. I have taken the security out of the equation by leaving a test WLAN open. Notebooks are working but anytime I add more than two Apple devices it starts acting up. I had TAC take a look and they are satisfied since the notebooks work. Apple has zero business class support (that I can find.) If anyone has any ideas please share...here is a link to the Apple discussion with details.


https://discussions.apple.com/message/16010989#16010989

Rusty Haferkamp Mon, 08/29/2011 - 06:29
User Badges:

Found the culprit to my problem. Switchport security was enabled. Changed it to trunk mode for the WLC and it works.

Vinay Sharma Mon, 08/29/2011 - 10:45
User Badges:
  • Gold, 750 points or more

Thanks for Sharing this Rusty :-). 5+



Regards,

Vinay Sharma

Community Manager- Wireless

Vinay Sharma Mon, 08/29/2011 - 10:49
User Badges:
  • Gold, 750 points or more

Hello Imad,


Could you try what Rusty suggested and share the results :-

Switchport security was enabled. Changed it to trunk mode for the WLC and it works.


Thanks,

Vinay Sharma

Community Manager- Wireless

ben2025wfm Thu, 04/24/2014 - 10:20
User Badges:

4 years later and I am having this issue with IPhone 4 and 4S only and with 1200 AP's running the last and EOL IOS.

I can't change the switch port as these are autonomous AP's. Location with WLC running 3600 AP's are fine.

Has anyone else found a fix? My company is too cheap to upgrade users to a IPhone 5.

Rasika Nayanajith Thu, 04/24/2014 - 15:48
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Hi Ben,

Would you able to post/attach "show run" output of your autonomous AP to check the config & see any possible issues 

HTH

Rasika

 

Rasika Nayanajith Sat, 05/03/2014 - 23:59
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

Hi,

Change your config like below & give it a try. It should work. Sometimes apple devices does not like WPA/TKIP instead prefer WPA2/AES.


dot11 ssid XXXXXXXXXX
  authentication key-management wpa version 2
!
interface Dot11Radio0
 no encryption vlan 3 mode ciphers tkip
 encryption vlan 3 mode ciphers aes-ccm

HTH

Rasika

**** Pls rate all useful responses. Each time you rate a response Cisco will donate $1 to Kiva ****

Actions

This Discussion