LMS 3.2 discovery issue

Answered Question
Nov 17th, 2009

Hello,

I just installed a new LMS 3.2 on a new station under Windows2003 in replacement of a LMS 2.6 under Windows2000.

I got an issue on the devices discovery process.

Normally, I should have 225 devices (found by LMS 2.6) and I got only about half of them.

I tried many configurations on the discovery settings without any success.

May be I missed something ?

Could you please help me ?

Thanks

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 3 weeks ago

To make your 3.2 discovery settings the same as 2.6, you should uncheck the Update DCR Display Name box, set Use DCR devices as seeds to true, and add the following CDP seed devices:

146.249.76.254

10.128.159.138

146.249.77.254

At that point, you could disable all discovery modules other than CDP, set your exclude filter back to the 2.6 ranges, then see if Discovery gives you what you want.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Thu, 11/19/2009 - 17:38

Post the NMSROOT/campus/etc/cwsi/DeviceDiscovery.properties file from the 2.6 server and the NMSROOT/conf/csdiscovery/CSDiscovery-config.xml file from the 3.2 server.  What are some of the devices found by 2.6 which are not found by 3.2?

ppoiron Thu, 11/19/2009 - 23:49

Hi Joe,

Some devices were not discovered by LMS 3.2 like MSFC2 on 6509 catalyst, or some switchs which are behind a firewall.

I put in 3.2 the same seed devices as in 2.6 and the results in discovery were different.

I tried several combinations in discovery settings between global setting and setting by modules (arp, rt, cdp) with exlude ip subnets.

At each configuration, a new discovery gives me different results.

Last time, I replaced exclude subnets by include subnets and it has been working.

You will find attached DeviceDiscovery.properties and CSDiscovery-config.xml.

Best regards,

Patrice

Joe Clarke Fri, 11/20/2009 - 05:43

It's good you were able to make it work.  However, it looks like you posted the original DeviceDiscovery.properties from your 2.6 server, so I cannot tell you what modifications you can make to your 3.2 config to better match your 2.6 settings.  If you post the actual DeviceDiscovery.properties from the 2.6 server, I can offer some insight.

ppoiron Fri, 11/20/2009 - 06:15

I'm sorry Joe, but I have posted LMS 3.2 files and not LMS 2.6 because this one is down since 3 days.

Correct Answer
Joe Clarke Fri, 11/20/2009 - 09:04

To make your 3.2 discovery settings the same as 2.6, you should uncheck the Update DCR Display Name box, set Use DCR devices as seeds to true, and add the following CDP seed devices:

146.249.76.254

10.128.159.138

146.249.77.254

At that point, you could disable all discovery modules other than CDP, set your exclude filter back to the 2.6 ranges, then see if Discovery gives you what you want.

ppoiron Mon, 11/23/2009 - 05:38

Many thanks.

I'm no longer on site, but I will ask customer to do test with your recommendations.

Actions

This Discussion