unableto connect to rvs 4000 behind another router

Unanswered Question

Good evening

I'am using a modem/router to conncet my lan to internet. unfortunetly it is impossible to switch off the router of my modem. So i connect my RVS 4000 on the modem/router and i assign it static ip as my modem has i disable the DHCP function on my RVS 4000. I m still using it because of its gigabit ethernet capability.

My problem is i am unable to connect to my RVS from the outside. inside the LAN no problem I just use its STATIC IP. I have a NAS on this LAN. I write a NAT/PAT rule in my modem/router to route HTTP and FTP and the port for the interface to my NAS. It's just working smoothly. But not for my RVS. I have checked the remote management and translate the traffic incoming on this port to the same port on the

Unsuccessfull !!. ok that can't be considered as external traffic.

so I disable remote management and all the protection firewall, DOS,BLOCK WAN REQUEST. I route the HTTP port 80 to port 80 I try to connect to /home.htm....unsucessfull !!

So if somebody have some idea about this problem ...I will be very glad !

thank you very much

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Te-Kai Liu Tue, 11/17/2009 - 15:02

Did you try remote management from a PC in the LAN of your modem router? If that does not work, you might want to give Tech Support  a call.

Alejandro Gallego Thu, 11/19/2009 - 06:35

Please correct me if I am wrong, but it seems that your topology is like this:

Modem/Router >>> RVS >>> LAN

IP for the above is one network:

So in other words you are connecting the RVS to the Modem/Router via a LAN port (numbered port) not its WAN (Internet port). If this is correct enabling remote management would have no effect as well any firewall option settings. With this in mind, forwarding port 8080 as its management port is useless, because the request is not being received on the RVS's WAN its being received on the LAN. Try to forward port 80 or 443 for HTTPS to the RVS from your Modem/Router and let us know if that worked.


Sorry, I just re-read your initial post and I understood that you have already port forwarded port 80 to the RVS. One thing that I would like to clarify is this; when you are connecting from the cloud are you sepcifying the address like this: http:///home.htm:8080 ?

If so, change that to this: http://

Note that there is no port specified as we are using port 80, the default for http. By also asking for 'home.htm' you are asking to go past the initial connection to the web interface and go directly to the home page, they dont like that. You will be redirected there once the connection is made.

David Carr Thu, 11/19/2009 - 07:13

Just an Idea.  If you want to remote manage the second router.  Whatever port you wanna use for management, for example 9000.  Forward that port from your modem/router to the Wan Ip address of the rvs4000.  Then once you do that setup remote management for port 9000 and connect to the rvs4000 using the modem/router wan ip address :9000 at the end.  This should forward you to the rvs4000 and allow you to remote manage the device.

Hello David

I try again with the remote management, but I think as allegall says if i do not use the wan port of the RVS the remote managment is out of service.

I switch on the remote management on the port 9000 and the https in the management my RVS.

I create a rule in my modem/router to forward port 9000 to the static IP of the RVS same port.

from the cloud i strike https://publicIP:9000          unsuccessfull

I try also the same thing with no DMZ           unsuccessfull

I try the same thing with 2 DMZ on for each router     unsuccessfull

Aie aie !

the problem seems to be hard to solve !

thank you for your help

hello alegalle

you are right with the topology of my network. the modem/router is connected on the port 1 of the RVS router, the WAN port is empty.

I have just checked this: on my modem/router i create a DMZ on the static IP the RVS. then i create a NAT/PAT rule to forward the http port 80 to IP my RVS port 80. i try this adress from the cloud http://publicIP/home.htm     : unsuccessfull

then http://publicIP/home.htm:80                      :unsuccessfull

I try the same with https: I create a NAT/PAT rule to forward https port 443 to IP my RVS port 443

then from the cloud I strike https://publicIP:443         unsuccessfull

https://publicIP/home.htm:443                              unsuccessfull

what is strange for me: is that's working with my NAS, attached on the port 3 of the RVS.

I create a rule (in the modem/router interface) to open its port and to forward it to the STATIC IP my NAS.

from the cloud I strike https://publicIP:port-my-NAS and that is working i access   the administration of my NAS.

I have also a photo server on this NAS. The redirection of the HTTP traffic just work fine to the NAS. I have access to my photos from the cloud.

there is some special feature with the RVS and the managment page that i don't know !

thank you anyway for your help !

David Carr Thu, 11/19/2009 - 10:23

The issue you are having is that your using just the lan ports and wanting to use the router functions of the router.  The acl's  and rules you can create on the router are when traffic goes from lan to wan and vice versa.  Since your going lan to lan the rules on the rvs4000 are not working.  All the rules you will have to create to access the devices plugged into the rvs4000 will have to be made on the modem/router.  The lan ports on the router with the way your using them is like that of a 10/1000 unmanaged switch.

Dear David

you are absolutely right !

At the moment i am using my RVS as a switch...what a pity ! and one of the reason is that I am unable to connect from the cloud. For example the DHCP function...I can disable this function on my modem/router and activate it on the RVS . but it's no help if i can't manage it from the clouds !

I ve tried  to stop the DHCP from my modem/router, to connect its cable on the WAN port of the RVS and i gave the DHCP to the RVS. but i was still unable to manage it from the clouds...

and that's the reason of my quest ! I have no doubt that my RVS is a far better router than my modem/router, but this modem will be all the way before my RVS...so before giving all the routing to my RVS i need to be able to manage it from behind my modem/router

thanks for your help

David Carr Thu, 11/19/2009 - 11:37

I do have an idea you can try.  If you setup the modem/router and forward all traffic to the wan ip of the rvs4000, it will give you management to the rvs4000 and fix your issue.  For example modem/router's wan has its public ip address of x.x.x.x and the lan is y.y.y.1.  Plug an ethernet cable from the modem/router into the wan port and have its ip address as y.y.y.2 and put all your traffic on the rvs4000's lan as z.z.z.1 - 254.  This will give you remote management and allow the modem/router to maintain the wan ip address.  Then you can use what port you want as management and in a sense use the rvs4000 as the router with the modem/router as a bridge.

hello david

just to check if i well understand what you suggest.

On my modem/router LAN: i can disable my firewall and the DHCP function. i declare the static IP my RVS  I create a DMZ on the static IP my RVS (mean to be sure all the traffic will go to the RVS ..?). I connect my modem/router on the WAN port of my RVS. and i give the routing and the firewall of the LAN to the RVS.

Is that correct ?

and so you think i shall be able to manage my RVS on the remote management port ?

If you think so I wanna try !

David Carr Thu, 11/19/2009 - 12:36

You would turn off DHCP on the modem/router cause you won't need it.  Then use the diagram as a guideline of setting up your network.  The ip addresses may be different but you get the drift.  You can try to disable the firewall but it might need to be on to forward all the traffic to the rvs4000's wan.


Thank you very much for your help the problem is solved !

David you were right. have a look on my actual diagram.

the thing difficult to understand for me was to set internet on static ip: and the gateway

now i can access all my routers and NAS from the cloud and also from LAN;)

thank you very much for your time and patience !

David Carr Fri, 11/20/2009 - 13:58

No problem, I am glad I could assist you and help you get that working.

Ryan Brown Mon, 10/29/2012 - 17:13

I know this thread is 3 years old but I have the exact same setup. I haven't tried changing anything that you have mentioned yet David but when I get off work I will give it a try. But the question that I have is I have a Actiontec wireless modem/router and the RVS4000 is connected to that router. My NAS is connected to the RVS4000 and my wireless printer is connected to the Actiontec. My computer and my wife's computer is also connected to the Actiontec wirelessly. My question is if all traffic gets forwarded to the RVS4000 would I and my wife be able to access the internet wirelessly though the Actiontec? If that is the case, would it be possible to turn the Actiontec basicly into an access point.

Thanks for any advice you would give.

How my network is setup it

Internet----->Actiontec Modem(IP:67.x.x.x)/Router (IP:>RVS4000 (IP:

I have another issue that I was wondering if you could help me with. When I use a seperate modem and connect the RVS 4000 and try to VPN in all works fine. I am able to access my network drive. The IP address that is given to the RVS 4000 is 67.x.x.x and the LAN is 192.168.200.x. But when I connect the Actiontec Modem/Router to the internet and then connect the RVS 4000 I am unable to VPN in from a different location. The Actiontec's WAN is 67.x.x.x and the LAN is and then the  RVS4000 gets a WAN IP of 192.168.100.x and the LAN is So what Im thinking is the the VPN can't find the RVS4000 behind the Actiontec.

Any suggestions

Heres a diagram to help out if I am confusing you

Internet---->Modem---->RVS4000 = successful VPN connection

Internet---->Actiontec Modem/Router----->RVS4000 = unsuccessfuly connection


This Discussion