CE520 server teaming?

Answered Question
Nov 19th, 2009

Hi,

I'm trying to get a Catalyst Express 520G switch to form a team with a server but no traffic is flowing.

If the two ports connecting to the server are set as switch ports you can set up the etherchannel and it shows as up on both ends but I can't get traffic to go over the link.

The server is a OSX 10.6 box so is using LACP bonding and it happily sees the link as up but you can not ping the server.  We have similar set ups on 3560 switches which work OK so I'm not sure if it is a limitation of the CE500s or I have the wrong smartport or other setting.  Though from the docs the only smartport that can make an etherchannel is the switch one. Any chance of getting a server team role?

Help :-)

Thanks

Nick

I have this problem too.
0 votes
Correct Answer by alissitz about 7 years 2 months ago

Hello Nick, I hope you are well.

Hearing that this works with the 3560 is very encouraging ... however I am not sure of where the problem is just yet.  Do you also have the configs from the 3560 in case we need to compare?  I would be interested to see if the 3560 is configured for access mode and not trunking mode.

Any chance you can attach the config of the CE500 to the case?

Etherchannel requires both sides to be configured the same ... however without knowing how you have things configured it is not clear where the disconnect is.

Here is the documentation, however it is not exactly as you are doing.  None-the-less, here it is:

http://www.cisco.com/en/US/docs/switches/lan/catalystexpress500/release_12.2_25_fy/user/guide/custom.html#wp143554

I would not configure the smart port to be switch mode unless the server is also configured for inter-switch operation (trunking mode).  Both sides have to match ...  Have you tried to statically set this up?

If you would be so kind to add some more details, I will endeaver to assist more.  Have a good night,

Andrew Lee Lissitz

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
alissitz Thu, 11/19/2009 - 14:44

Hello Nick, I hope you are well.

Hearing that this works with the 3560 is very encouraging ... however I am not sure of where the problem is just yet.  Do you also have the configs from the 3560 in case we need to compare?  I would be interested to see if the 3560 is configured for access mode and not trunking mode.

Any chance you can attach the config of the CE500 to the case?

Etherchannel requires both sides to be configured the same ... however without knowing how you have things configured it is not clear where the disconnect is.

Here is the documentation, however it is not exactly as you are doing.  None-the-less, here it is:

http://www.cisco.com/en/US/docs/switches/lan/catalystexpress500/release_12.2_25_fy/user/guide/custom.html#wp143554

I would not configure the smart port to be switch mode unless the server is also configured for inter-switch operation (trunking mode).  Both sides have to match ...  Have you tried to statically set this up?

If you would be so kind to add some more details, I will endeaver to assist more.  Have a good night,

Andrew Lee Lissitz

nickbrooker Thu, 11/19/2009 - 16:30

Hi,

thanks for the prompt reply.

The 3560 config for one bond is..

benefitz-sw2#sh run int gi 0/1
Building configuration...

Current configuration : 146 bytes
!
interface GigabitEthernet0/1
description etherchannel link 1
switchport mode access
channel-group 1 mode active
spanning-tree portfast
end

benefitz-sw2#sh run int gi 0/2
Building configuration...

Current configuration : 146 bytes
!
interface GigabitEthernet0/2
description etherchannel link 1
switchport mode access
channel-group 1 mode active
spanning-tree portfast
end

benefitz-sw2#sh run int po 1
Building configuration...

Current configuration : 55 bytes
!
interface Port-channel1
switchport mode access
end

benefitz-sw2#

I did some more testing and found I can get the MAC address in the ARP table for the bond but no response on ping or open ports. So maybe the problem is a service order problem so I'll cehck that one out further. Is there anyway to find out exactly how the port is set with the switch smartport setting? I'll read ovr the doc you mention as well.

Thanks

Nick



nickbrooker Thu, 11/19/2009 - 16:39

Hi,

the VLAN was the answer, thanks.  I tagged VLAN1 and it got a DHCP address straight away.

So some feedback for the CE500 switch guys would be to give us a server team smartport setting that does not require tagging of VLAN1! And maybe also give us the command line equivalent or summary of what the smart port roles do o we now how to set the other end.

Thanks again for the point in the right direction...

Nick

alissitz Thu, 11/19/2009 - 17:22

Glad to hear it is all well now.

I would suggest to look at the server configs as well, interesting solution you found.

In the 3560 configs, these ports are set to access mode, by default in vlan 1, vlan 1 is untagged, and then etherchannel configured to use the LACP protocol.

If you have time, and this is not a production system, I might suggest a few extra steps to make sure you have the best solution.

Configure the CE500 w/ the smart port role of either 'server' or 'other'.  Make sure the vlan is set to 1.  This will make the port an access port and part of vlan 1.  Vlan 1 will be untagged.  Then, configure the etherchannel.

If the 3560 does not require vlan tagging, then I would not think that the UC500 needs it either.  It also sounds like your server is expecting vlan 1 to be tagged?  Have you verified the configs for the server?

If you cannot try these config options out, then that is fine.  It is good to hear that you have everything up and going.

Do please let me know if I can be of assistance to you.  Kindest regards and good night,

Andrew

Actions

This Discussion