NEC IPK II and Cisco CME -- No DTMF Touch Tones

Answered Question
Nov 5th, 2009
User Badges:

I am currently attempting a SIP integration between an existing NEC Electra Elite IPK II PBX system and a new Cisco CME/UE implementation using a Cisco 2821 Integrated Services Router.


So far, I've been able to successfully follow the setup documentation to get all the voice calling up and running with great success (for those who may be new to this like I am, here is the guide I used for the NEC components-- http://www.connect-comm.com/NEC_SIPTrunkConnections.pdf). The NEC is the primary system in the picture so all calls from the Cisco side are sent through the NEC system and routed out accordingly.



The issue I have, however, is that touch tone (DTMF) services aren't working properly. All DTMF going TO the Cisco system work perfectly. All DTMF going FROM the Cisco system result in two conditions depending on dtmf-relay and dtmf-interworking settings on the Cisco configuration and DTMF Relay Mode on the NEC Programming Data section 84-13...



All Cisco modes with NEC DTMF Relay Mode set to Disabled produce a clicking sound on the non-Cisco side, so you know it's getting the signals, just not processing them properly. Furthermore, all Cisco modes with NEC DTMF Relay mode set to RFC2833 produce the same clicking EXCEPT for Cisco dtmf-relay rtp-nte, which DOES trigger the first touch tone... except the tone hangs and never stops until the call is disconnected, and no follow-up tones are triggered (although a packet scan reveals they are being sent and received).



If anyone here has worked on this system combination or experienced similar situations, I'd appreciate any advice and suggestions. I have attached my config file stripped of any accounts/passwords.

Correct Answer by Paolo Bevilacqua about 7 years 4 months ago

Have you tried ?


nte-end-digit-delay

and possibly

dtmf-interworking rtp-nte

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Paolo Bevilacqua Thu, 11/05/2009 - 09:19
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Have you tried ?


nte-end-digit-delay

and possibly

dtmf-interworking rtp-nte

muranskycotech Thu, 11/05/2009 - 09:57
User Badges:

I've tried various combinations of dtmf-relay and dtmf-interworking but resulting in the results above.


I have not tried nte-end-digit-delay, so I'll try that this afternoon. Should I use it in conjunction with other settings?



UPDATE: You are officially the hero of the day! The nte-end-digit-delay parameter solved the problem perfectly! Thank you very much!

Paolo Bevilacqua Thu, 11/05/2009 - 10:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Very good, obscure commands must be there for a reason after all.


Thank you for the nice rating and good luck!

Actions

This Discussion