Windows DHCP issues with PC connected to Cisco IP Phone

Unanswered Question
Nov 20th, 2009

I have seen a lot of posts on this topic but can't seem to find one with an actual resolution. We just upgraded to the last SCCP firmware (8.1.2) for 7940G and 7960G IP phones on a 6.1.2 Cluster.  We are having sparodic issues with the PCs getting an IP address from the DHCP server following the upgrade. The IP Phone gets a DHCP address from the same DHCP server without an issue. If I unplug the PC from the IP Phone and go directly to the switch I get an IP address. I can then unplug the PC and reconnect everything back via the IP phone and all still works.   I can even then release and renew from the PC without an issue.

Check DHCP server and scopes. Plenty of available address and when I connect the PC directly I instantly get an IP address.

Previous firmware load was 8.0.9

Any ideas?

Catalyst 3560G swich running 12.2(50)SE

interface GigabitEthernet0/12
switchport access vlan 130
switchport mode access
switchport voice vlan 800
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0022.641f.6784
switchport port-security mac-address sticky 0021.5504.7450 vlan voice
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust device cisco-phone
auto qos voip cisco-phone
storm-control broadcast level 70.00
storm-control action shutdown
spanning-tree portfast
service-policy input AutoQoS-Police-CiscoPhone

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Md. Mijanur Rahman Mon, 11/23/2009 - 20:32

I am surprised seeing train of commands at your port config, simply use the following commands on the port and have a try:


interface GigabitEthernet0/12

switchport access vlan 130
switchport mode access
switchport voice vlan 800

mls qos trust device cisco-phone

spanning-tree portfast


Additionally you can use port-security commands later if it work fine.


paulcian_2 Tue, 11/24/2009 - 05:13

What we have done so far is isolate the issue related to the IOS version on the switch.  The switch is a 3560G running 12.2(50)SE.  We just upgraded one of our switches to 12.2(50)SE3 and the problem seems to have gone away.  Also, we do not have this issue on a Catalyst 6509 (Cat OS 8.1.3) or 3550 (12.2(50)SE3).

I have contacted TAC to confirm this is the issue.


This Discussion