CUOM 2.2: PIFServer process doesn't start.

Unanswered Question
Nov 20th, 2009

Dear Folks,

CUOM 2.2 doesn't able to start the PIFServer process



c:\>
pdshow PIFServer
Process= PIFServer
State = Failed to run
Pid = 0
RC = -2
Signo = 1073741822
Start = N/A
Stop = 11/20/2009 2:24:31 PM
Core = Not applicable
Info = Application failed or was registered incorrectly.

From PIFServer.log file
Informational:  ANIServer starting Cisco Process Manager communication thread
The connection with the server has been established
java.lang.NullPointerException
at com.cisco.nm.ani.server.framework.POStore.setNextDbId(POStore.java:883)
at com.cisco.nm.ani.server.framework.POStore.computeNextDbIds(POStore.java:918)
at com.cisco.nm.ani.server.framework.POStore.internalPopulateDataModel(POStore.java:1413)
at com.cisco.nm.ani.server.framework.POStore.populateDataModel(POStore.java:1491)
at com.cisco.nm.ani.server.frontend.AniMain.loadFromDatabase(AniMain.java:355)
at com.cisco.nm.ani.server.frontend.AniMain.dynamicInitialize(AniMain.java:441)
at com.cisco.nm.ani.server.frontend.AniMain.main(AniMain.java:554)
ANI Server failed to load from the database.
Please stop and restart the system. You may need to re-initialize the database.
If this does not work, please contact technical support.
I re-initialized the DB but no changes affect the PIFServer process...
Anyone knows what I'm hitting?
Ciao
Leonardo
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nael Mohammad Sat, 12/19/2009 - 04:51

Post the pdshow output from the dos prompt:

"pdshow > pdshow.txt"  and check you event viewer for any errors as well with a screenshot.

-nael

Actions

This Discussion