Cisco 3745 Digital Modems not passing data.

Unanswered Question

I have configured a Cisco 3745 for both Dialin and out connectivity

the configuration is, an application server designed to communicate directly with RS-232 com ports with attached modems

will utilising an IP based software offering virtual com ports with virtual modems attached.

Dialout is operating correctly where by the Server call a remote host. The redirection software will telnet to the Cisco 3745 and a call is generated from the DM to a remote client device.

Dialin is where the problem occures. The Server is configured to listening for a telnet session from the Cisco 3745.

Inspection shows the call is accepted by the Dial in lines and the autocommand initialises a call to the host server which has a virtual com port with virtual configured modem listening and waiting.

when the remote device calls the Cisco 3745, the call is answered and the session is forwarded to the Server, however almost instantly the Cisco issues a command (+++) to terminate the connection between the DM and the TCP Virtual com port / modem. Data does not pass to the server and the call is dropped.

Cisco 3745

version 12.3

Config Line Info

line 97 98

no motd-banner

no exec-banner

exec-timeout 0 0

no vacant-message

modem Dialin

modem autoconfigure type Mica

autocommand telnet Server 7000 /stream

transport preferred all

transport input telnet

transport output telnet

escape-character NONE

The Com redirect software is supplied by a reputable cisco recommneded vendor

Any direction would be appreciated.

Many Thanks

Larry_s

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Debug Results

*Mar  1 00:40:20.023: %SYS-5-CONFIG_I: Configured from console by console
*Mar  1 00:43:46.523: Modem 3/0 Mica: configured for Answer mode, with Null signaling, 0x0 tone detection.
*Mar  1 00:43:46.655: Modem 3/0 Mica: in modem state CALL_SETUP
*Mar  1 00:43:46.675: Modem 3/0 Mica: in modem state CONNECT
*Mar  1 00:43:47.059: Modem 3/0 Mica: in modem state LINK
*Mar  1 00:43:50.203: Modem 3/0 Mica: in modem state RANGING
*Mar  1 00:43:52.523: %ISDN-6-CONNECT: Interface Serial1/1:2 is now connected to XXXXXXX
*Mar  1 00:43:54.083: Modem 3/0 Mica: in modem state HALF_DUPLEX_TRAIN
*Mar  1 00:43:56.075: Modem 3/0 Mica: in modem state TRAINUP
*Mar  1 00:43:58.175: Modem 3/0 Mica: in modem state EC_NEGOTIATING
*Mar  1 00:43:58.603: Modem 3/0 Mica: in modem state STEADY
*Mar  1 00:43:58.603:  Modem 3/0 Mica: received ConnectInfo
*Mar  1 00:43:58.619: Modem 3/0 Mica: CONNECT at 31200/28800 (Tx/Rx), V34+, LAPM, V42bis
*Mar  1 00:43:58.907: TTY97: DSR came up
*Mar  1 00:43:58.907: tty97: Modem: IDLE->(unknown)
*Mar  1 00:43:58.907: TTY97: EXEC creation
*Mar  1 00:43:58.907: TTY97: pause timer type 1
*Mar  1 00:44:01.707: Modem 3/0 Mica: in modem state TERMINATING
*Mar  1 00:44:01.707:  Modem 3/0 Mica: received TerminateInfo
*Mar  1 00:44:01.731: Modem 3/0 Mica: in modem state IDLE
*Mar  1 00:44:01.759: Modem 3/0 Mica: DISCONNECT after 00:00:15, due to reason (0x8220) EC rcvd DISC frame.
*Mar  1 00:44:01.759: %CALLRECORD-3-MODEM_CALL_REC_ERROR: DS0 slot/contr/chan=1/1/2, slot/port=3/0, call_id=23, userid=(n/a), ip=0.0.0.0, calling=4660960, called=8200, std=V34+, prot=LAPM, comp = V42bis init-rx/tx b-rate=28800/31200, finl-rx/tx b-rate=28800/31200, rbs=0, d-pad=None, retr=0, rx/tx chars=91/47, bad=0, rx/tx ec=5/2, bad=0, total moh time=0 sec, current moh time=0 sec, moh count=0, moh status=0x0, call waiting retrains=0, moh req=0, encoder/decoder state=0xFF/0xFF, rx/tx comp ratio=0.00:1/0.00:1, rx/tx dict reset=0/0, time=15, finl-state=STEADY, disc(modem)=8220 Rx (line to host) data flushing - OK/EC condition - locally detected/receiv

+++ call breakdown.gif

The image indicates the call from the Virtual interface perspective. Red indicates information  originating from the Router to the Virtual modem

The edge device is either sending the +++ or the router DM is sending the +++ because it cannot understand the data from the remote modem.

Debug Results

*Mar  1 00:40:20.023: %SYS-5-CONFIG_I: Configured from console by console
*Mar  1 00:43:46.523: Modem 3/0 Mica: configured for Answer mode, with Null signaling, 0x0 tone detection.
*Mar  1 00:43:46.655: Modem 3/0 Mica: in modem state CALL_SETUP
*Mar  1 00:43:46.675: Modem 3/0 Mica: in modem state CONNECT
*Mar  1 00:43:47.059: Modem 3/0 Mica: in modem state LINK
*Mar  1 00:43:50.203: Modem 3/0 Mica: in modem state RANGING
*Mar  1 00:43:52.523: %ISDN-6-CONNECT: Interface Serial1/1:2 is now connected to XXXXXXX
*Mar  1 00:43:54.083: Modem 3/0 Mica: in modem state HALF_DUPLEX_TRAIN
*Mar  1 00:43:56.075: Modem 3/0 Mica: in modem state TRAINUP
*Mar  1 00:43:58.175: Modem 3/0 Mica: in modem state EC_NEGOTIATING
*Mar  1 00:43:58.603: Modem 3/0 Mica: in modem state STEADY
*Mar  1 00:43:58.603:  Modem 3/0 Mica: received ConnectInfo
*Mar  1 00:43:58.619: Modem 3/0 Mica: CONNECT at 31200/28800 (Tx/Rx), V34+, LAPM, V42bis
*Mar  1 00:43:58.907: TTY97: DSR came up
*Mar  1 00:43:58.907: tty97: Modem: IDLE->(unknown)
*Mar  1 00:43:58.907: TTY97: EXEC creation
*Mar  1 00:43:58.907: TTY97: pause timer type 1
*Mar  1 00:44:01.707: Modem 3/0 Mica: in modem state TERMINATING
*Mar  1 00:44:01.707:  Modem 3/0 Mica: received TerminateInfo
*Mar  1 00:44:01.731: Modem 3/0 Mica: in modem state IDLE
*Mar  1 00:44:01.759: Modem 3/0 Mica: DISCONNECT after 00:00:15, due to reason (0x8220) EC rcvd DISC frame.
*Mar  1 00:44:01.759: %CALLRECORD-3-MODEM_CALL_REC_ERROR: DS0 slot/contr/chan=1/1/2, slot/port=3/0, call_id=23, userid=(n/a), ip=0.0.0.0, calling=xxxxxx, called=8200, std=V34+, prot=LAPM, comp = V42bis init-rx/tx b-rate=28800/31200, finl-rx/tx b-rate=28800/31200, rbs=0, d-pad=None, retr=0, rx/tx chars=91/47, bad=0, rx/tx ec=5/2, bad=0, total moh time=0 sec, current moh time=0 sec, moh count=0, moh status=0x0, call waiting retrains=0, moh req=0, encoder/decoder state=0xFF/0xFF, rx/tx comp ratio=0.00:1/0.00:1, rx/tx dict reset=0/0, time=15, finl-state=STEADY, disc(modem)=8220 Rx (line to host) data flushing - OK/EC condition - locally detected/receiv

+++ call breakdown.gif

The image indicates the call from the Virtual interface perspective. Red indicates information  originating from the Router to the Virtual modem

The edge device is either sending the +++ or the router DM is sending the +++ because it cannot understand the date drom therek

Paolo Bevilacqua Mon, 11/23/2009 - 10:26

*Mar  1 00:44:01.759: Modem 3/0 Mica: DISCONNECT after 00:00:15, due to reason (0x8220) EC rcvd DISC frame.

Can you try a different client modem or configure it differently.

And we did not mentioned MICA firmware to be latest ?

Actions

This Discussion