Microsoft Virtual PC .1Q 3750 routing issues

Answered Question
Nov 23rd, 2009

Case study: I am seeking help as I am attempting to test the .1Q functionality of Microsoft Virtual PC (only). What I have done is connected a PC w 1gig NIC configured for .1Q tagging and connected it to a Cat 3750 trunk port. I configured 3 VLAN (one per virtual environment) and I created a loopback interface to ping too.

Problem: PING not successful. I am able to see the VLAN tagged on the 3750 and when I show ARP on the 3750 I do see the MAC of the Virtual PC with the correct VLANID but the switch will not route the packet to the LO int. Hence, PING failure. I tried with both no routing and with EIGRP both, to no avail.

Attached is a diagram with info, the IOS is LAN IP not sure version but there are no other config’s on the 3750 it is clean fresh out of the box. I have to use this set as I am limited additional devices due to security policies.

Any suggestions or recommendation would be greatly appreciated. I am leaning towards Microsoft VM the root cause but just not sure. The ping should route and respond.

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 7 years 1 week ago

briangrides wrote:

Jon,

Now that I think about it, (we did our testing on Fri) we never did set up the virtual pc's we started with just trying to get the PC itself ping either the vlan (default gateway ip) or the lo int ip. Both to no avail. One question I thought of is I am wondering if there is a issue with facing a trunk port and a NIC interface together, and something getting scrambled in the middle? In most cases one would not interface a trk to a pc it would be an access port. Could this fact be an issue, that you can think of? Microsoft PC is a 2007 application no one really does what I am attempting to do, in this fashion most enterprise environments would use a VMware 4.0 Hypervisor but we have a fire-wire requirement and VMware does not support fire-wire interfaces at this time. Your help is greatly appreciated!

Brian

Had a quick trawl through technet and google and i can't find any mention of virtual PC supporting 802.1q. I can find mention of something called HyperV which seems to be used for server virtualisation and this can support 802.1q tagging.

If your NIC supports 802.1q tagging and for this you need to check the NIC vendor support site then i don't think your issue is with the NIC or the 3750, assuming they have been configured properly but rather with the virtual PC software. It may be worth posting a question on technet to see if they know if virtual PC works with 802.1q tagging.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Mon, 11/23/2009 - 10:58

Can you post

1) the config of the 3750


2) the ouput of a "sh interface trunk" from the 3750

Jon

briangrides Mon, 11/23/2009 - 11:47

Jon,

The router is no longer connected to the PC running MVPC. I believe that the sh ip int does will not bar any useful information at this time.

Can you tell me what you are interested in seeing? I should be able to recall the answer? The router is at my desk un connected to anything (this posses the difficulty with me trying to figure this out, poor environment etc..) When the LAN guy has more time I will take the rtr to his desk, but I will not have internet connectivity.

Anything you think of for me to look for, I will and respond back once I able to!

The links was up-up

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

run config

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

no aaa new-model

switch 1 provision ws-c3750g-24ts-1u

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback1

ip address 10.2.1.1 255.255.255.255

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/28

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 10.1.1.1 255.255.255.0

!

interface Vlan20

ip address 10.1.2.1 255.255.255.0

!

interface Vlan30

ip address 10.1.3.1 255.255.255.0

!

ip classless

ip http server

!

!

!

control-plane

!

!

line con 0

line vty 0 4

no login

line vty 5 15

no login

!

!

end

Jon Marshall Mon, 11/23/2009 - 11:55

Brian

I wanted to the config just to give it a quick check over.

The "sh interface trunk" output was so i could see what the switch thought was happening on the trunk link.

One question. You couldn't ping the loopback address on the 3750 but from the PC could you ping each of the vlan interfaces ?

Jon

briangrides Mon, 11/23/2009 - 12:23

Jon,

NOPE, unable to get a ping to the vlan either. Note: we only tried 1 vlan we didnt set up all the virtuals we wanted to make sure we could ping first. The PC was able to successfully ping intself (10.1.1.2) One thing I noticed with sh ip arp (during ping from PC to sw: ping 10.1.1.1) was that the packet entered the switch with the correct vlan10 tag and virtual mac add, BUT, the dest ip adress was 10.1.1.255 (the B-Cast ip) not the ip we pinged: 10.1.1.1

I do not understand this?

Jon Marshall Mon, 11/23/2009 - 12:39

briangrides wrote:

Jon,

NOPE, unable to get a ping to the vlan either. Note: we only tried 1 vlan we didnt set up all the virtuals we wanted to make sure we could ping first. The PC was able to successfully ping intself (10.1.1.2) One thing I noticed with sh ip arp (during ping from PC to sw: ping 10.1.1.1) was that the packet entered the switch with the correct vlan10 tag and virtual mac add, BUT, the dest ip adress was 10.1.1.255 (the B-Cast ip) not the ip we pinged: 10.1.1.1

I do not understand this?

Brian

Haven't used vritual PC so not sure how it does things. Just to clarify though, the packet with a destination of 10.1.1.255 you saw, that was definitely the ping packet was it ?

Jon

briangrides Mon, 11/23/2009 - 12:55

Jon,

YES from desktop dos we ping 10.1.1.1 and the arp table showed vlan10 10.1.1.255  The source vlan ip configured on the NIC profile is 10.1.1.2

briangrides Mon, 11/23/2009 - 12:50

Jon,

Now that I think about it, (we did our testing on Fri) we never did set up the virtual pc's we started with just trying to get the PC itself ping either the vlan (default gateway ip) or the lo int ip. Both to no avail. One question I thought of is I am wondering if there is a issue with facing a trunk port and a NIC interface together, and something getting scrambled in the middle? In most cases one would not interface a trk to a pc it would be an access port. Could this fact be an issue, that you can think of? Microsoft PC is a 2007 application no one really does what I am attempting to do, in this fashion most enterprise environments would use a VMware 4.0 Hypervisor but we have a fire-wire requirement and VMware does not support fire-wire interfaces at this time. Your help is greatly appreciated!

Correct Answer
Jon Marshall Mon, 11/23/2009 - 13:21

briangrides wrote:

Jon,

Now that I think about it, (we did our testing on Fri) we never did set up the virtual pc's we started with just trying to get the PC itself ping either the vlan (default gateway ip) or the lo int ip. Both to no avail. One question I thought of is I am wondering if there is a issue with facing a trunk port and a NIC interface together, and something getting scrambled in the middle? In most cases one would not interface a trk to a pc it would be an access port. Could this fact be an issue, that you can think of? Microsoft PC is a 2007 application no one really does what I am attempting to do, in this fashion most enterprise environments would use a VMware 4.0 Hypervisor but we have a fire-wire requirement and VMware does not support fire-wire interfaces at this time. Your help is greatly appreciated!

Brian

Had a quick trawl through technet and google and i can't find any mention of virtual PC supporting 802.1q. I can find mention of something called HyperV which seems to be used for server virtualisation and this can support 802.1q tagging.

If your NIC supports 802.1q tagging and for this you need to check the NIC vendor support site then i don't think your issue is with the NIC or the 3750, assuming they have been configured properly but rather with the virtual PC software. It may be worth posting a question on technet to see if they know if virtual PC works with 802.1q tagging.

Jon

Actions

This Discussion