OID does not work

Unanswered Question
Nov 23rd, 2009
User Badges:

hello ,

I would ask you for this question

Model number                    : WS-C2960G-48TC-L

Please find here below my answers to your questions :

1)     All I know is that the customer is pooling this MIB (1.3.6.1.4.1.9.9.276.1.4) in command line, from a unix station. But, here in our lab, we tried the same thing, using Snmpwalk and it’s not working (NULL value) . For all the others MIB we have tested, it worked fine.

2)     This was tested with the 12.2(44)SE and 12.2(52)SE who are supposed to support this MIB.

3)     From what I know, there are no issues with other OIDs.

Best regards

Hamsofiane

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hamsofiane Tue, 11/24/2009 - 01:15
User Badges:

Hello ,


Thank you for your response, I tried this with   this OID1.3.6.1.4.1.9.9.276.1.4 but the result is not


good i have a NULL Value.


I do not understand what do you mean about the [What comes next is the interface ID.] can you please


give me an exemple please.



Best regards

Hamsofiane

Collin Clark Tue, 11/24/2009 - 09:18
User Badges:
  • Purple, 4500 points or more

I walked one of my switches and for that particular switch, my interfaces are indexed starting at 10001. The first valid OID for this switch is  1.3.6.1.4.1.9.9.276.10001. You need to find out what your interface indexes are and then adjust the OID.

You can find the interface indexes with the following command-
show snmp mib ifmib ifindex


Example Output-
FastEthernet0/1: Ifindex = 10001
FastEthernet0/2: Ifindex = 10002
FastEthernet0/3: Ifindex = 10003

As you can see, the interface index from the switch matches my functional OID.

Actions

This Discussion