MGX to MGX packet Loss.

Answered Question
Nov 23rd, 2009

Hi Friends,


I am facing packet Loss problem with MGX to MGX connectivity. I have an IMA PNNI link between two MGX. I also have a UNI connection to two routers. the connection diagram is provided below.

Router1 <-> MGX <-> MGX <-> Router2

when i ping from router1 to router 2, i am facing approx 25% packet loss.

Can anyone please suggest what can i check to resolve the issue.

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 7 years 1 month ago

Hello Raijv,

you say you see 25% of losses on the ping test.

How many ATM E1 links are members of the ATM IMA?

use for troubleshooting IMA

http://www.cisco.com/en/US/tech/tk39/tk356/technologies_tech_note09186a0080093d52.shtml

I see that you have modified the max differential delay on IMA. This can have an effect

I've seen several posts from you about issues with MGX; unfortunately I've noticed that documentation about this WAN switches (no speed or duplex settings here this is ATM and MGX doesn't run IOS) is not good or complete.

Unfortunately I had limited exposure to MGX so I can be of limited help.

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
tetong Mon, 11/23/2009 - 23:33

Hi Rajivdasmohapatra,

Have you check the switch port speed and duplex mode? By default, Cisco device is set to auto auto mode try hardcode speed and duplex mode.

Regards,

Tan

Rajiv Dasmohapatra Mon, 11/23/2009 - 23:41

Hi Tan,

I have created IMA links between the routers and the MGX. given below is the configurations of one router

controller E1 0/0/0
mode atm aim 0
framing NO-CRC4
clock source internal
!
interface ATM0/IMA0
ip address 40.40.40.5 255.255.255.0
ima differential-delay-maximum 75
no atm ilmi-keepalive
pvc IMA-VC 1/200
  cbr 1000
  encapsulation aal5snap
!
!
interface ATM0/0/0
no ip address
scrambling-payload
ima-group 0
atm uni-version 4.0
no atm ilmi-keepalive

Where should i put the speed and duplex, in the ATM0/0/0?


tetong Tue, 11/24/2009 - 00:03

Hi Rajivdasmohapatra,

Have you patch your MGX to latest IOS version? As i know the latest IOS version resolve packet loss problem.

Regards,

Tan

Rajiv Dasmohapatra Tue, 11/24/2009 - 01:46

Hi Tan,

I believe, I already have the latest version. provided below is the dspversion of MGX.

Image Type   Shelf Type    Card Type         Version   Built On
  ----------   ----------   ----------    ------------   ------------
     Runtime          MGX        PXM1E      5.5(0.201)   Dec 31 2008, 06:03:57
     Boot          MGX        PXM1E      5.5(0.201)   -

Regards,

Rajiv

tetong Tue, 11/24/2009 - 08:09

Hi Rajivdasmohapatra,

Do you see any packet loss between MGX to MGX?

Any packet loss PING from router to local MGX?

Regards,

Tan

Correct Answer
Giuseppe Larosa Thu, 11/26/2009 - 10:30

Hello Raijv,

you say you see 25% of losses on the ping test.

How many ATM E1 links are members of the ATM IMA?

use for troubleshooting IMA

http://www.cisco.com/en/US/tech/tk39/tk356/technologies_tech_note09186a0080093d52.shtml

I see that you have modified the max differential delay on IMA. This can have an effect

I've seen several posts from you about issues with MGX; unfortunately I've noticed that documentation about this WAN switches (no speed or duplex settings here this is ATM and MGX doesn't run IOS) is not good or complete.

Unfortunately I had limited exposure to MGX so I can be of limited help.

Hope to help

Giuseppe

Rajiv Dasmohapatra Fri, 11/27/2009 - 03:49

Hello Giuseppe,

How are you? thank you for helping me with my earier posts.

Regarding the MGX, I have one Member until you asked me the question. surprisingly, adding another link to the IMA group cut down my losses by about 6 to 7 %. earlier i have one IMA link and was getting 25% loss n average. now i have two links and am getting 12% to 15% loss average.

any suggestions?

cheers..

Rajiv

marikakis Fri, 11/27/2009 - 04:45

I am not very familiar with MGX either. Still, I wanted to ask if there is a specific reason for setting "clock source" to "internal" instead of "line" under E1 controller. When connecting routers to switches the typical configuration is "line" because the switches have better clock stratum levels than the routers.

Actions

This Discussion

Related Content