conference and MOH

Answered Question
Nov 24th, 2009
User Badges:

Dear all,

Sorry, for the following long paragraphs, but, really it is a very strange scenario.

Issue concernig the conference and Music on hold.


When an IP phone inside my company intiate a conference even with also inside other IP phones or outside calls, and this intiator IP phone make hold; all rest conference participants hear each other carefully without any interupption.


Problem comes up when an outside caller intiate a conference with an IP phone inside my company and others outside my company, this inside IP phone make hold; all rest conference participants will hear Music on hold and can't complete the conference.


So, if you please, if there is a solution for this issue. If not, how to global disable the MOH at all.


Note: My CCM is 4.2(3).



Appreciated for your help.

Correct Answer by rupam_chakra1983 about 7 years 7 months ago

To disable MOH for all user

you have to navigate to MOH server configuration and set the run flag to No


Plz let me know whether it resolved your issue.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rupam_chakra1983 Tue, 11/24/2009 - 02:54
User Badges:

Search for the service parameter

Suppress Music on Hold to Conference Bridge


and change te value to true.


Plz rate the post if you found it useful

rupam_chakra1983 Tue, 11/24/2009 - 04:32
User Badges:

Hi


Plz note the two pint.


1. When u initiate a conference call from your IP phone in that case you are using the CUCM conferennce resources and the parameter is for the call manager only hence it is working fineb as per the configuration.


2. When a PSTN external user is putting the call on hold in that case the PSTN external user's service provider is generating the moh and your call manger has no ontrol on it it just treat it as a normal audio stream


hence you can control your audio stream but not for pstn.


hope this will help you plz rate this post .


Thanks

Ahmed Yassin Tue, 11/24/2009 - 04:39
User Badges:

Sorry, you didn't understand my case correctly, as in second case when initiate a conference call from outside and one of the conference is participate in this conference, when he press hold, the other external participants hear our CCM MOH not the PSTN MOH.


So, how i cancel it at all even inside.

Jaime Valencia Tue, 11/24/2009 - 09:03
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

If i understand correctly the answer is already provided.

If you're the one invited to a conference from someone external and you're not using a CFB controlled by CUCM then you're just in a call as you could call/be called by anyone in the world.

The parameter only kicks in when you're using a CFB controlled by CUCM.


If you're making a call or receiving a call then you need to disable the MOH on the GW, obviusly this will affect all calls you make/receive on the GW but there is no other way, tell your users to press mute instead.


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

Ahmed Yassin Tue, 11/24/2009 - 14:02
User Badges:

Try it by yourself and you will see that if inside IP phone to external conference and pressed hold all external participants will hear your own MOH, so how it will be by PSTN. Make a lab and try and you will see it by yourself.

Thx for help

j.huizinga Wed, 11/25/2009 - 03:30
User Badges:
  • Silver, 250 points or more

The inside IP phone doesn't know it is part of a conference, so when the IP phone presses the hold button, the CM will stream MoH to the other party which happen to be a conference.

It problably will also work the other way around. When there are 3 IP phones in a conference and an external user is included and is presses the hold button on their Nortel, Siemens, Avaya phone, the inside IP phone users might also hear the remote MoH stream from the Nortel, Siemens, Avaya PBX.


Jan

Ahmed Yassin Wed, 11/25/2009 - 03:45
User Badges:

yes, you are right and on the spot.

So, final conclusion is to solve such problem to disable the MOH and no other solution is available.


Thx a lot for your reply

Correct Answer
rupam_chakra1983 Wed, 11/25/2009 - 21:46
User Badges:

To disable MOH for all user

you have to navigate to MOH server configuration and set the run flag to No


Plz let me know whether it resolved your issue.


Thanks

Ahmed Yassin Thu, 12/03/2009 - 01:29
User Badges:

Sorry, for being late for this reply for some personal res

ons.


Thx a lot, your answer solved the problem.

Actions

This Discussion

Related Content