Recommended upgrade from CUCM 6.1(2)...?

Unanswered Question
Nov 24th, 2009
User Badges:

The upgrade path in the matrix suggests i can upgrade to any of the recent 6.1(4)x updates.


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp78319


The trouble is, there seems to be no clear way to determine if a release is stable/relatively bug free.  I had already downloaded and merged the "6.1(4)SU1"  ISO files.  However, i now note that an even newer upgrade "6.1(4a)SU2" is available.  Can anyone shed light on the naming convention of these upgrades (4) (4a) (4 SU1) etc...  Also - is the latest release necessarily the one i should install?


Im going to install and test an upgrade in our lab first, and was going to use 6.1(4)SU1......



Thoughts appreciated.



Rgds

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jonathan Schulenberg Tue, 11/24/2009 - 13:02
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

The latest release does not always mean it is the most stable release. You should always carefully evaluate the open bugs for a release before moving to it. Keep in mind that the appliance model does allow you to roll back to your previous versions easily if something unexpected arrises.


The versioning works like this:
6.1(4)

6.1(4)SU1

6.1(4a)

6.1(4a)SU1

6.1(4a)SU2

etc..

andy_vvc2 Wed, 11/25/2009 - 02:31
User Badges:

I might be mistaken, but when i browse the Cisco site for Unified Application upgrades (to CUCM) i cant see 4aSU1 listed... i see 4SU1 and then 4aSU2....  I think an upgrade to 6.1(4a)SU1 would make sense as this is one release back from current.  But i cant locate it  !

Tommer Catlin Tue, 11/24/2009 - 14:27
User Badges:
  • Green, 3000 points or more

I have to say most of the 6.14 versions are stable.   Im going to upgrade 6.12 to 6.14 next week in preparation to upgrade to 7.1.3.x.  I cant go from 6.12 to 7.13 from the looks of it.

andy_vvc2 Wed, 11/25/2009 - 03:02
User Badges:

Hi all - is this link the correct (valid) upgrade instruction to go from 6.1(2) to 6.1(4)x  ?


http://cisco.com/en/US/docs/voice_ip_comm/cucm/cucos/6_1_1/cucos/iptpch7.html#wp1040189


The doco states it is for upgrading to 6.1x from 5.x or  6.x

I can't locate a newer doc than this in the 'Upgrade' docs area:


http://www.cisco.com/en/US/customer/products/sw/voicesw/ps556/prod_installation_guides_list.html


Is this valid, or is there a newer doc hidden in the depths of the Cisco website?


I have already downloaded and then merged the ISO parts for the August 6.1(4)SU1 update.  I will most likely use this in the test lab unless someone can point me toward 6.1(4a)SU1...?  [Im not certain what the 'a' refers to in the release versions!]

Tommer Catlin Wed, 11/25/2009 - 07:44
User Badges:
  • Green, 3000 points or more

Actually, its probably in the Release notes for that version, but any of the 6.1.x to 6.1.4.x are basically the same.   DRS your system, (backup)  Id personally reboot the cluster before hand so its "clean slate".


Download the (2) files from CCO to upgrade to 6.1.4 (whichever one you want)

Merge the files (see the release notes to copy 1of2 and 2of2 into one file)

Startup an SFTP server.  I use Minicore SFTP server (google it and download exe)

Go to the OS GUI of CUCM (publisher first)

Software upgrade

point to your SFTP

Upgrade.


Takes about an hour or so, the reboot can take a little longer than normal.  After is done, repeat on each Subscriber.


After reboot and wait about 15 minutes, check the RTMT log for dbreplication is in a safe range.  (2, 2,4)


Id also recommend rebooting your phones after the upgrade.  Possibly will be new firmware packaged in the upgrade.

Actions

This Discussion