Clientless SSL VPN - url bypass

Unanswered Question
Nov 24th, 2009

Hello all,

We are publishing some Sharepoint application thru SSL VPN for external users.

The application guys asked if it's possible to pass a url directly from the application thru the SSL VPN?

Something like https://ssl.company.com/moss/isi11/default.aspx, whereas https://ssl.company.com is the url to access SSL VPN.

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cleidh_mor Tue, 11/24/2009 - 15:48

Hi,


Do you mean via the webvpn portal or via the AnyConnect client?

Cheers,
Neil

cleidh_mor Wed, 11/25/2009 - 12:18

I'm not sure you can link directly using the webvpn portal, although you can certainly create a URL for the relevant connection profile and publish it that way.  So if you could create a connection profile specifically for that application, you can publish the URL as something like https://.// and then use a re-direct in the portal page to go to the root page of the app

manfernandez Sun, 11/29/2009 - 08:46

I had a similar issue where I was bookmarking a URL and then the webpage was calling for an internal URL.  It was for a bank and they were hosting the check images on another internal server.  So when the repoffice teller clicked on the link for the check image it called a URL by IP (they should have used names instead )

How I fixed the problem:

On the Bookmark make sure you enable smart tunnel

SmartTunnel.jpg

All connections the URL calls will use the tunnel.  You may have to play with where you call the URL from either from the bookmark itself or from an internal landing page.

Hope this helps

Manny

manfernandez Sun, 11/29/2009 - 08:46

I had a similar issue where I was bookmarking a URL and then the webpage was calling for an internal URL.  It was for a bank and they were hosting the check images on another internal server.  So when the repoffice teller clicked on the link for the check image it called a URL by IP (they should have used names instead )

How I fixed the problem:

On the Bookmark make sure you enable smart tunnel

SmartTunnel.jpg

All connections the URL calls will use the tunnel.  You may have to play with where you call the URL from either from the bookmark itself or from an internal landing page.

Actions

This Discussion