cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
996
Views
0
Helpful
3
Replies

QOS - Polycom traffic over 2MB Serial

colmgrier
Level 1
Level 1

Polycom teleconference traffic requires 1.2 MB (bandwidth). Site A has 2 x 2MB serial circuits to Site B.

What is best pratice to apply QOS on both serial interfaces (ingress/egress) on both sites.

Please advise.

### Site A  Router ###

access-list 104 permit tcp any any range 3230 3243
access-list 104 permit udp any any range 3230 3285

class-map match-all POLYCOM-CONF
match access-group 104

policy-map POLY-POLICY
class POLYCOM-CONF

class class-default
fair-queue

interface Serial3/0:0
description "Link to Site B"
bandwidth 2048
ip address 10.218.92.25 255.255.255.252
ip load-sharing per-packet
service-policy output POLY-POLICY
service-policy input POLY-POLICY


interface Serial3/1:0
description "Link to Site B"
bandwidth 2048
ip address 10.218.92.21 255.255.255.252
ip load-sharing per-packet
service-policy output POLY-POLICY
service-policy input POLY-POLICY

### Site B Router ###

access-list 104 permit tcp any any range 3230 3243
access-list 104 permit udp any any range 3230 3285

class-map match-all POLYCOM-CONF
match access-group 104

policy-map POLY-POLICY
class POLYCOM-CONF
priority xxxx

class class-default
fair-queue

interface Serial3/0:0
description "Link to Site A"
bandwidth 2048
ip address 10.218.92.25 255.255.255.252
ip load-sharing per-packet
service-policy output POLY-POLICY
service-policy input POLY-POLICY


interface Serial3/1:0
description "Link to Site A"
bandwidth 2048
ip address 10.218.92.21 255.255.255.252
ip load-sharing per-packet
service-policy output POLY-POLICY
service-policy input POLY-POLICY

1 Accepted Solution

Accepted Solutions

Hello Colm,

>> If I apply 1200kbps (PQ) for teleconference traffic on both serial interfaces, does this allow all traffic 'default' to use the full 2mb on both serial interfaces when teleconference is not being used?

yes, this is the elasticity of LLQ CBWFQ

Hope to help

Giuseppe

View solution in original post

3 Replies 3

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Colm,

nice to hear from your you

you are using load sharing per packet so each flow will see its packets sent in round robin over the two serial links.

you need also to provide enough resources in case one link has failed.

I would use a class-map with bandwidth 1200 kbps on both links

class-map polycom

! your match condition here a simple ACL should be enough

match access-group 111

I see you want to use priority command that is possible too in that case I would use priority 1200

in normal conditions only 600 kbps will be used on each link.

Unused resources are available to other traffic classes so this is not a problem to have priority 1200 on interface

Be also aware that if the two links have different delays and / or are going though different WAN provider(s) switches there is potential for out of order that can be a problem.

incoming policy doesn't play a key role here

Hope to help

Giuseppe

Hi Giuseppe,

Thanks for the below info.

If I apply 1200kbps (PQ) for teleconference traffic on both serial interfaces, does this allow all traffic 'default' to use the full 2mb on both serial interfaces when teleconference is not being used?

Giuseppe wrote...

Unused resources are available to other traffic classes so this is not a problem to have priority 1200 on interface

### Config to be applied to both Routers ####

access-list 104 permit tcp any any range 3230 3243
access-list 104 permit udp any any range 3230 3285

class-map match-all POLYCOM-CONF
match access-group 104

policy-map POLY-POLICY
class POLYCOM-CONF
priority 1200
class class-default
fair-queue

interface Serial3/0:0
bandwidth 2048
ip address 10.218.92.25 255.255.255.252
ip load-sharing per-packet
service-policy output POLY-POLICY


interface Serial3/1:0
bandwidth 2048
ip address 10.218.92.21 255.255.255.252
ip load-sharing per-packet
service-policy output POLY-POLICY

Regards,

Colm

Hello Colm,

>> If I apply 1200kbps (PQ) for teleconference traffic on both serial interfaces, does this allow all traffic 'default' to use the full 2mb on both serial interfaces when teleconference is not being used?

yes, this is the elasticity of LLQ CBWFQ

Hope to help

Giuseppe

Review Cisco Networking products for a $25 gift card