Extension Mobility Service Redundancy Configuration (urgent)

Unanswered Question

Hi,

I want to configuring extension mobility service in redundancy.. there are two cucm servers (cucm1:10.0.0.1 and cucm2:10.0.0.2). currently the url for extension mobility that i am using is following:

http://10.0.0.1:8080/emapp/EMAppServlet?device=#DEVICENAME#

and the system > enterprise parameter (ccmadmin page) has the following information.

URL Authentication: http://10.0.0.1:8080/ccmcip/authenticate.jsp


URL Directories http://10.0.0.1:8080/ccmcip/xmldirectory.jsp


URL Information  http://10.0.0.1:8080/ccmcip/GetTelecasterHelpText.jsp


URL Services http://10.0.0.1:8080/ccmcip/getservicesmenu.jsp

now when i shut down the ccm1 server i cant get the extension mobility service. so i removed the ip addres of cucm1 server and instead replace it with name (CCMIP).

Extension mobility service :http://CCMIP:8080/emapp/EMAppServlet?device=#DEVICENAME#

URL Authentication: http://CCMIP:8080/ccmcip/authenticate.jsp

URL Directories http://CCMIP:8080/ccmcip/xmldirectory.jsp
URL Information  http://CCMIP:8080/ccmcip/GetTelecasterHelpText.jsp
URL Services http://CCMIP:8080/ccmcip/getservicesmenu.jsp

because there is no dhcp and dns server here so i configured cisco router as a dns server (but no dhcp server configuration i configured ip phones manually) and done the following config on cisco router

config)# dns server

config)# ip host CCMIP 10.0.0.1 10.0.0.2

i also entered the dns server IP manually in IP phones as well as CUCM server (by using command set network dns [primary/secondary] <ip address>). Even then i am getting error of "Host not found".. am i missing something or there is another way to configure it.

Regards

Naresh Rathore

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
brunonogaki Sat, 11/28/2009 - 02:57

Hi,

Once I had this problem, and I figured out I was missing domain-name in the IP Phones.

But in my case I was running a Microsoft DNS Server, and DHCP on routers...

Regards,

Bruno

hi,

There is issue of dns resolution.. because when i used dns server (router) on my pc its even not resolving the ip...following is the thing which i did.

there are 3 routers connected to a switch (R1 1.1.1.1 acting as host, R2 1.1.1.2 as dns server, R3 1.1.1.3 ip i want to ping)... Following si the R1 config...

R1(config)#ip name-server 192.168.3.80

R1(config)#ip domain name yourdomain.com

following is the R2 (dns server) config

R2(config)# ip dns server

R2(config)# ip domain name yourdomain.com

R2(config)# ip host ccmip 1.1.1.3

and configured only IP on R3 router when on R1 i ping ccmip.. the ping is successful.. but when i replace pc with R1.. the ping is unsuccessful...R2 is unable to resolve the address.. there is no domain system.,..

can check at ip phones what is the problem so i used pc as the host....missing some domain configuration or sth..I opened a case for it lets see what hapens....

tell me about your config.. you just entered the name in the dns server .. mentioned the domain name (for eg. abc.com) manually in the phone and it worked!!!!!!

Regards

Naresh

brunonogaki Sat, 11/28/2009 - 03:35

Yeah...

Seens to be some DNS resolution issue, and not a CUCM issue.

In my case, my customer had a Microsoft DNS Server, and he just entered 2 more records named ccmcluster pointing to Publisher and Subscriber.

The PCs could ping ccmcluster, because they were all in the same domain, trying to reach ccmcluster.domain.com.

In the case of IP Phones, they were not in the domain, so they couldn't reach ccmcluster.

What I did was to configure a domain-name in DHCP for phones. And it worked.

In CUCM, I pointed those parameters in Enterprise Parameters and EM Service to ccmcluster instead of IP, just like you did.

But in your case, you are trying to configure the DNS Server in the router. And sorry, I have never done that...

Look if this link can help you:

http://blog.ioshints.info/2006/09/use-your-cisco-router-as-primary-dns.html

Regards,

Bruno

brunonogaki Sat, 11/28/2009 - 03:53

Hi,

No, just ccmcluster worked for me.

I have not tried the FQN...

Bruno

Actions

This Discussion