UCCX change DOC location

Answered Question
Nov 24th, 2009
User Badges:

Hello all,


On my UCCX system I have the German language installed.  In the DOC repository unde de_DE I have a directory called IT. I have placed an XML file here.


When my script runs it should look here and read this file. However a reactive debug tells me that the script is looking in en_GB\en_DE\IT\.


I thought that by setting the script language to de_DE this would correct the problem but it hasn't. How can I correct this and get the script to look in the correct location for the XML file?


Thanks,

Correct Answer by Jonathan Schulenberg about 7 years 5 months ago

Yes; use the language qualifier I referenced in my last answer.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jonathan Schulenberg Tue, 11/24/2009 - 12:43
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

I presume en_GB is the system default? Where did you change the language for the script?

csg-admin Tue, 11/24/2009 - 13:36
User Badges:

Yes the default language in system settings is set to English UK en_GB.


In the script I used the language variable and set this to de_DE.

Jonathan Schulenberg Tue, 11/24/2009 - 13:45
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Creating a language variable does nothing unless you apply it. You can qualify the specific language against the document at your Create XML Document step using an @ qualifier; or, possibly just specify DOC[de_DE\filename.xml] in the parameter.


The qualifier is explained in the Expression Language Reference document, page 152:

http://tools.cisco.com/search/display?url=http%3A%2F%2Fwww.cisco.com%2Fen%2FUS%2Fdocs%2Fvoice_ip_comm%2Fcust_contact%2Fcontact_center%2Fcrs%2Fexpress_7_0%2Fuser%2Fguide%2Fuccx70edexlan.pdf&pos=1&strqueryid=1&websessionid=lD-Xx8Azcm985JNcwnm9uHX


My answer to a previous post may also shed some light on language control within CCX/IPIVR:

https://supportforums.cisco.com/message/1054653#1054653

csg-admin Wed, 11/25/2009 - 03:15
User Badges:

Thanks for your help.  Even if I set the location to DOC[de_DE\filename.xml] the

system insists on searching en_GB\de_DE\filename.xml.  So if

I put the xml file in this location it works but this is not how I want it to work.  Is there anything else I can check?

Correct Answer
Jonathan Schulenberg Wed, 11/25/2009 - 06:49
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Yes; use the language qualifier I referenced in my last answer.

csg-admin Wed, 11/25/2009 - 07:32
User Badges:

Yep that worked!


In my variable I used DOC[IT\filename.xml] @ L[de_DE]


Thank you.

Actions

This Discussion