SIP TRUNK to gsm gateway

Unanswered Question
Nov 24th, 2009
User Badges:

Hi,

I'm working with a uc500.

I'm trying to implement a trunk sip to a gsm gateway. I made the test with the gsm gateway and a sip client on my pc without problem.

When I redirect the call to the uc500 I can't do any call towards a mobile phone. I test the outgoing dial plan without any problem.I don't know exacly the problem.

May you help me?

I attached sip  debug


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Maulik Shah Wed, 11/25/2009 - 11:02
User Badges:
  • Silver, 250 points or more

The logs show no debugs for a call so its unclear what the issue is. Here are a few questions:


- did you configure the sip trunk using CCA for the UC500 pointing to the GSM gateway

- would need to look at a config for the box

- what is the flow that is failing exactly - call from GSM to UC500 phone?

- Debug log when you actually make a call would help

stefanotiburzi Thu, 11/26/2009 - 07:00
User Badges:

Hi Maulik,

thanks for your interest, in the following the answers to your questions, I hope will be useful:

- Yes, I configure the sip trunk using CCA for the UC500 pointing to the GSM gateway

- I attached the configuration

-the flow that have problem is from the uc500 ip phone to gsm gateway


For the debug, I try tomorrow to go to the customer, If there is some debug more useful please tell me. Now I can give you the diagnostic from the gsm gateway for a generic call to a mobile;now the outgoing  dial plan have a sip trunk like default connection and than BRI :




Nov 26 15:36:34] SIP read from IP (192.168.5.10:62584) INVITE  sip:[email protected]:5060 SIP/2.0

[Nov 26 15:36:34] Write to  IP (192.168.5.10:5060) SIP/2.0 404 Not Found

[Nov 26 15:36:34] SIP read  from IP (192.168.5.10:5060) ACK sip:[email protected]:5060  SIP/2.0


I hope this is useful


Bye

Attachment: 
Steven Smith Mon, 11/30/2009 - 14:10
User Badges:
  • Gold, 750 points or more

Looking at the log you posted, it appears that the GSM gateway rejected the call with a 404, which means it doesn't know how to route the call, or it doesn't think the number is valid.  What format does your gateway want to receive the calls?  Does it want a leading 9?

stefanotiburzi Mon, 12/07/2009 - 04:04
User Badges:

My line number is 0. I try to modified the gsm configuration with or without 0, but nothing happen. Now I try to upgrade the gsm gateway, but It seems that the problem was in the UC also because I try the gsm gateway with a 3cx phone over my pc and everything was correct.I give you my conf.


Any ideas?

Attachment: 
Steven Smith Mon, 12/07/2009 - 16:15
User Badges:
  • Gold, 750 points or more

The 404 means it doesn't like the number that it received.  The number looks correct from what I can see.  It would be hard for me to see what the problem is.  Interestingly enough, the IP address in the config doesn't match your IP address in the log you posted.

stefanotiburzi Wed, 12/09/2009 - 05:09
User Badges:

Who doesn't like the number, the gsm gateway or the uc500?however 192.168.5.50 is the gsm gw IP, and 192.168.5.10 is the SBCS IP.


Thanks


bye

Steven Smith Wed, 12/09/2009 - 08:05
User Badges:
  • Gold, 750 points or more

It looks like the GSM gateway doesn't like the number that the UC500 is sending.  It is probably a formating issue, but we are getting 404 back.

Actions

This Discussion