CiscoWorks IPM 4.1.0 - SNMP Community String Updates

Unanswered Question
Nov 24th, 2009

Cisco NetPro,

We're running IPM 4.1.0 on Solaris 10.

Periodically we change SNMP RO/RW strings on our devices.  I recently changed the strings on our devices and within IPM.

Now that they're changed, 26 of my collectors are appearing in the Source Not Responding list.  Both my Source and Target devices have the same strings configured.

I need to verify the strings IPM has stored.  I exported my collectors via the command line utility "ipm" and via the GUI and still no strings in the output.

How can I see the SNMP strings in IPM?

Stephanie

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 11/24/2009 - 10:33

The community strings are stored in DCR in the cmf database.  IPM does not hold on to them in its database, but perhaps the old strings are still in memory.  Try restarting the IPMProcess daemon:

pdterm IPMProcess

pdexec IPMProcess

Then see if the sources and responders become reachable.

slcornish Tue, 11/24/2009 - 10:48

Ok, thanks.

I'm still a little confused.  Originally I had 254 collectors with status "Source Not Responding".  I went to IPM->Collector Management->Devices->All Devices to select my device and afterwards selected Edit Device Credentials to update the strings.  Afterwards I selected the collectors and selected Reconfigure.  I ended up with 26 collectors left with status "Source Not Responding".

How can I see which strings IPM is using?

Stephanie

Joe Clarke Tue, 11/24/2009 - 11:19

A sniffer trace of all SNMP traffic between the server and source device will be your best bet.  However, you can also export the DCR credentials for your source devices under Common Services > Device and Credentials > Device Management.  Those are the credentials IPM should be using.

slcornish Tue, 11/24/2009 - 11:48

I ran "pdterm IPMProcess" followed by "pdexec IPMProcess"  and now I'm getting this error:

Error

Error in communicating with IPMGroupAdministration Server.
It may be down or not yet up. Please make sure that the IPMGroupAdministration Server is up and running, then refresh the page.

Stephanie

Joe Clarke Tue, 11/24/2009 - 11:57

Check the pdshow output to see if IPMOGSServer also went down.  If it did, pdexec this daemon, and you should be back up.

slcornish Tue, 11/24/2009 - 12:13

That worked and so far I have no collectors with status "Source Not Responding".  Thanks for your help.

I did change them via IPM->Collector Management->Devices by updating their credentials so what does this do since the strings are also stored in the DCR?

Stephanie

Joe Clarke Tue, 11/24/2009 - 12:55

You'll note that the Edit Device Credentials button in IPM sends you over to Common Services to edit the credentials.  All of the credentials are stored in DCR, and only in DCR.

jakewilson Sun, 01/24/2010 - 06:24

I think IPM might be primarily SNMP based.  NetFlow for what I've learned is available on Cisco routers, some Switches and the ASA.  Googling on NetFlow will display several vendors that report on NetFlow.  Fluke, Caligare, NFA make good products.  My favorites are NTOP and Scrutinizer: 

http://www.ntop.org/overview.html (also make a great probe)

http://www.plixer.com/products/netflow-sflow/free-netflow-scrutinizer.php  (we develop).

Jake

Actions

This Discussion

Related Content